comparison debian/rules @ 4909:56a8fbdd6090 stable

debian: use pybuild and dh_sphinxdoc Use pybuild because it's kind of standard nowadays. Use sphinxdoc debhelper to have a Depends: libjs-sphinxdoc and common files (JS/CSS) symlinked.
author Denis Laxalde <denis.laxalde@logilab.fr>
date Fri, 11 Oct 2019 17:05:37 +0200
parents 6292fe564b20
children ddfc0b16c9d7
comparison
equal deleted inserted replaced
4908:320c53900d4a 4909:56a8fbdd6090
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 #export DH_VERBOSE=1 2 #export DH_VERBOSE=1
3 3
4 %: 4 %:
5 dh $@ --with python2 --buildsystem=python_distutils 5 dh $@ --with python2,sphinxdoc --buildsystem=pybuild
6 6
7 override_dh_auto_build: 7 override_dh_auto_build:
8 dh_auto_build 8 dh_auto_build
9 # Workaround for Sphinx in Debian Buster defaulting to Python 3 9 # Workaround for Sphinx in Debian Buster defaulting to Python 3
10 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs 10 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs