comparison debian/rules @ 6136:95500f2f0966

debian: changes to build only for Python 3
author Faheem Mitha <faheem@faheem.info>
date Sun, 09 Jan 2022 23:05:28 +0530
parents 187bd6ade465
children 0562705ae984
comparison
equal deleted inserted replaced
6134:0fa9cc8075aa 6136:95500f2f0966
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 #export DH_VERBOSE=1 2 #export DH_VERBOSE=1
3 3
4 %: 4 %:
5 dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild 5 dh $@ --with python3,sphinxdoc --buildsystem=pybuild
6 6
7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS))) 7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
8 override_dh_auto_build: 8 override_dh_auto_build:
9 dh_auto_build 9 dh_auto_build
10 # Workaround for Sphinx in Debian Buster defaulting to Python 3 10 # Workaround for Sphinx in Debian Buster defaulting to Python 3
11 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs 11 SPHINXBUILD="python3 -m sphinx -bhtml" $(MAKE) -C docs
12 endif 12 endif
13 13
14 hgsrc_defined: 14 hgsrc_defined:
15 # Use "! -z" instead of "-n", because "-n" without arguments is true 15 # Use "! -z" instead of "-n", because "-n" without arguments is true
16 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) 16 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
18 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) 18 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
19 override_dh_auto_test: hgsrc_defined 19 override_dh_auto_test: hgsrc_defined
20 cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist 20 cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
21 endif 21 endif
22 22
23 override_dh_python2:
24 # avoid conflict with mercurial's own hgext3rd/__init__.py
25 find debian -path '*/hgext3rd/__init__.py' -delete
26 dh_python2
27
28 override_dh_python3: 23 override_dh_python3:
29 # avoid conflict with mercurial's own hgext3rd/__init__.py 24 # avoid conflict with mercurial's own hgext3rd/__init__.py
30 find debian -path '*/hgext3rd/__init__.py' -delete 25 find debian -path '*/hgext3rd/__init__.py' -delete
31 dh_python3 26 dh_python3
32 27