comparison debian/rules @ 6522:bf9ffcabaa20 stable

packaging: use python3 instead of python in debian/rules Looks like `python` doesn't exist for certain setups, and also using python3 explicitly is better (considering our .deb building scripts/infrastructure only supports Python 3).
author Anton Shestakov <av6@dwimlabs.net>
date Fri, 07 Apr 2023 15:52:26 -0300
parents 0562705ae984
children
comparison
equal deleted inserted replaced
6504:db0fd1f1a7d0 6522:bf9ffcabaa20
14 # Use "! -z" instead of "-n", because "-n" without arguments is true 14 # Use "! -z" instead of "-n", because "-n" without arguments is true
15 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) 15 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
16 16
17 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) 17 ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
18 override_dh_auto_test: hgsrc_defined 18 override_dh_auto_test: hgsrc_defined
19 cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist 19 cd tests && python3 $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
20 endif 20 endif
21 21
22 override_dh_python3: 22 override_dh_python3:
23 # avoid conflict with mercurial's own hgext3rd/__init__.py 23 # avoid conflict with mercurial's own hgext3rd/__init__.py
24 find debian -path '*/hgext3rd/__init__.py' -delete 24 find debian -path '*/hgext3rd/__init__.py' -delete