comparison debian/rules @ 4913:cac7e750422f stable

debian: also build with python3 We build with Python 3 along with Python 2. The binary package will contain the extension for both python version. This is to ease transition until the mercurial package in Debian uses Python 3. The documentation is still built with Python 2 because it needs Mercurial (which is currently Python 2).
author Denis Laxalde <denis.laxalde@logilab.fr>
date Fri, 11 Oct 2019 16:53:52 +0200
parents ddfc0b16c9d7
children 187bd6ade465
comparison
equal deleted inserted replaced
4912:43e9bb4de6b5 4913:cac7e750422f
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 #export DH_VERBOSE=1 2 #export DH_VERBOSE=1
3 3
4 %: 4 %:
5 dh $@ --with python2,sphinxdoc --buildsystem=pybuild 5 dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
6 6
7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS))) 7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
8 override_dh_auto_build: 8 override_dh_auto_build:
9 dh_auto_build 9 dh_auto_build
10 # Workaround for Sphinx in Debian Buster defaulting to Python 3 10 # Workaround for Sphinx in Debian Buster defaulting to Python 3
23 override_dh_python2: 23 override_dh_python2:
24 # avoid conflict with mercurial's own hgext3rd/__init__.py 24 # avoid conflict with mercurial's own hgext3rd/__init__.py
25 find debian -path '*/hgext3rd/__init__.py' -delete 25 find debian -path '*/hgext3rd/__init__.py' -delete
26 dh_python2 26 dh_python2
27 27
28 override_dh_python3:
29 # avoid conflict with mercurial's own hgext3rd/__init__.py
30 find debian -path '*/hgext3rd/__init__.py' -delete
31 dh_python3
32
28 override_dh_auto_clean: clean-docs 33 override_dh_auto_clean: clean-docs
29 dh_auto_clean 34 dh_auto_clean
30 rm -f tests/*.err 35 rm -f tests/*.err
31 36
32 clean-docs: 37 clean-docs: