view debian/rules @ 5724:0257716d1f22 stable

doc: update MQ To Evolve refugee book Updated the MQ Rosetta stone to improve style and remove deprecated commands. Changes include: - replace deprecated commands with current equivalents - added documentation for qimport and qcommit - changed 'odiff' in Cheat sheet to 'pdiff' to match detailed description - add in-line formatting of commands - add syntax aware highlighting to examples in literal blocks - tweaked wording in a few places - standardized formatting of file
author Chuck Tuffli <chuck@tuffli.net>
date Wed, 30 Dec 2020 11:01:37 -0800
parents 187bd6ade465
children 95500f2f0966
line wrap: on
line source

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild

ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
override_dh_auto_build:
	dh_auto_build
	# Workaround for Sphinx in Debian Buster defaulting to Python 3
	SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs
endif

hgsrc_defined:
	# Use "! -z" instead of "-n", because "-n" without arguments is true
	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test: hgsrc_defined
	cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext3rd/__init__.py
	find debian -path '*/hgext3rd/__init__.py' -delete
	dh_python2

override_dh_python3:
	# avoid conflict with mercurial's own hgext3rd/__init__.py
	find debian -path '*/hgext3rd/__init__.py' -delete
	dh_python3

override_dh_auto_clean:
	dh_auto_clean
	rm -f tests/*.err
	$(MAKE) -C docs clean