Mercurial > evolve
view debian/rules @ 1296:23819e1d61fd stable
evolve: add -i flag to amend command
The -i flag was missing because it is not a global flag of the commit command.
We can't make it a global flag yet as it is used in many places where it would
not be appropriate so we just add it for this occurrence.
Also, we only want to add it when commit supports it (otherwise it wouldn't
work with older versions of mercurial)
author | Laurent Charignon <lcharignon@fb.com> |
---|---|
date | Thu, 23 Apr 2015 17:45:46 -0700 |
parents | f0978cb993a0 |
children | 9590332b26c8 |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2 --buildsystem=python_distutils override_dh_auto_build: dh_auto_build $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 override_dh_auto_clean: clean-docs dh_auto_clean rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst