view tests/testlib/common.sh @ 5614:24a1ff0677a7 stable

compat: rename update() to _update() to make room for a new update() The next patch will add a `compat.update()` that delegates to the new `merge.update()` from upstream (different from the old one, which was renamed to `merge._update()`).
author Martin von Zweigbergk <martinvonz@google.com>
date Fri, 02 Oct 2020 09:51:45 -0700
parents e1c26c632b6d
children 55589cb47581
line wrap: on
line source

. $TESTDIR/testlib/pythonpath.sh

mkcommit() {
   echo "$1" > "$1"
   hg add "$1"
   hg ci -m "$1"
}

getid() {
   hg log --hidden --template '{node}\n' --rev "$1"
}

cat >> $HGRCPATH <<EOF
[alias]
debugobsolete=debugobsolete -d '0 0'
EOF