Mercurial > evolve
view debian/rules @ 1124:25e8f9c43f8a
debian: remove clean target before implicit match rule
This is redundant because it is a match-everything rule. Possibly a
typo.
author | Faheem Mitha <faheem@faheem.info> |
---|---|
date | Sat, 11 Oct 2014 02:02:05 +0530 |
parents | d6c065a7a6b1 |
children | f14163c7275a |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2 --buildsystem=python_distutils build: dh build --with python2 --buildsystem=python_distutils $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 clean: clean-docs rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst .PHONY: build clean clean-docs