Mercurial > evolve
view debian/rules @ 1046:296d48e1f55a
evolve: gather evolve output together
We stop relying on ui.status being muted when --quiet is used. Instead we use
plain write and hide this behind an explicite ui.quiet check.
This will help use enforcing this output in the comming --confirm mode.
author | Pierre-Yves David <pierre-yves.david@fb.com> |
---|---|
date | Fri, 08 Aug 2014 23:11:09 -0700 |
parents | 38099dfdcbbe |
children | d6c065a7a6b1 |
line wrap: on
line source
#!/usr/bin/make -f clean %: dh $@ --with python2 --buildsystem=python_distutils build: dh build --with python2 --buildsystem=python_distutils $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 clean: clean-docs rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst .PHONY: build clean clean-docs