Mercurial > evolve
view debian/control @ 1363:2eaa2943f9f3
directaccess: use cached filteredrevs
Before this patch we were calling directly repoview.computehidden(repo) to
compute the revisions visible with direct access, without going through the
caching mechanism for the filtered revisions.
There was two issues with that:
(1) Performance: We were not leverating the cached values of the 'visible' revs
(2) Stability: If there were to be a cache inconsistency with the computation of
'visible' we would crash in the branchmap consistency check partial.validfor.
Consider the scenario of rebase with bookmarks:
- when we delete a bookmark on an obsolete changeset (like what rebase
does when moving the bookmark after rebasing the changesets)
- then this changes the value returned by repoview.computehidden(repo) as
bookmarks are used as dynamic blockers in repoview.computehidden(repo)
- as of now, we don't invalidate the cache in the case of bookmark change
- if we have a cached value from before the bookmark change,
repoview.filterrevs(repo, 'visible') considers the cached value correct and
returns something different than repoview.computehidden(repo)
- in turn, if we use repoview.computehidden(repo) in directaccess, the subset
relationship is broken and the cache consistency assertion (parial.validfor)
fails if branchmap.updatecache is called in this time window
This patch leverages the caching infrastructure in place to speed up the
computation of the filteredrevs for visible-directaccess-nowarn and
visible-directaccess-warn. Incidentally it prevents the bug discussed in (2)
from crashing when running a rebase with a bookmark. Note that there still
needs to be a fix in core for the case discussed in (2).
The test for this side of the fix (not core's fix for (2) is very hard to
implement without introducing a lot of dependencies and does not belong
here. It is much easier to have the test of the fix for the scenario (2) in
core along with the fix.
author | Laurent Charignon <lcharignon@fb.com> |
---|---|
date | Sat, 13 Jun 2015 11:14:07 -0700 |
parents | 783aa685c5d4 |
children | 160968654581 |
line wrap: on
line source
Source: mercurial-evolve Section: vcs Priority: optional Maintainer: Logilab <contact@logilab.fr> Uploaders: Julien Cristau <julien.cristau@logilab.fr>, Pierre-Yves David <pierre-yves.david@logilab.fr>, Standards-Version: 3.9.3 Build-Depends: mercurial (>= 3.4~), python, debhelper (>= 8), python-sphinx (>= 1.0.8), imagemagick, librsvg2-bin, wget, Python-Version: >= 2.6 Homepage: https://bitbucket.org/marmoute/mutable-history Package: mercurial-evolve Architecture: all Depends: ${python:Depends}, ${misc:Depends}, mercurial (>= 3.3~), Description: evolve extension for Mercurial This package provides the experimental "evolve" extension for the Mercurial DVCS. . This extension provides several commands to mutate history and deal with issues it may raise. . It also: - enables the "Changeset Obsolescence" feature of mercurial, - alters core command and extension that rewrite history to use this feature, - improves some aspects of the early implementation in Mercurial 2.3. . **These extensions are experimental and are not meant for production.**