Mercurial > evolve
view debian/rules @ 894:4f21a3279a60
evolve: add function to deprecate an alias
When cleaning up the UI for evolve we will deprecate old aliases,
but still want them to work for a while. This is a helper function
that will be called during the extension setup and has the ability
map an old alias to a new or canonical one.
author | Olle Lundberg <geek@nerd.sh> |
---|---|
date | Fri, 04 Apr 2014 00:30:56 +0200 |
parents | d3bfd03cb26e |
children | 38099dfdcbbe |
line wrap: on
line source
#!/usr/bin/make -f clean %: dh $@ --with python2 --buildsystem=python_distutils build: dh build --with python2 --buildsystem=python_distutils $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 clean: clean-docs clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst .PHONY: build clean clean-docs