Mercurial > evolve
view debian/rules @ 1191:583f7f03434b stable
init: don't abort Mercurial on version mismatch
Evolve causes Mercurial to exit if there is a version mismatch, even
if no evolve command is invoked. This is a headache for people who
have to work with multiple versions of Mercurial. Instead, raise an
ImportError, which gives a warning but otherwise allows Mercurial to
run non-evolve commands.
author | Matt Mackall <mpm@selenic.com> |
---|---|
date | Tue, 23 Dec 2014 14:29:16 -0600 |
parents | f0978cb993a0 |
children | 9590332b26c8 |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2 --buildsystem=python_distutils override_dh_auto_build: dh_auto_build $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 override_dh_auto_clean: clean-docs dh_auto_clean rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst