Mercurial > evolve
view debian/rules @ 902:69872cef6053 stable
tests: fix test-prune.t breakage
test-prune.t was broken due to 91d28bd0e04e in upstream Mercurial, which made
hidden commits visible when a local tag made the commit reachable. The fix is to
delete the tag in the test.
author | Durham Goode <durham@fb.com> |
---|---|
date | Mon, 07 Apr 2014 16:41:29 -0700 |
parents | d3bfd03cb26e |
children | 38099dfdcbbe |
line wrap: on
line source
#!/usr/bin/make -f clean %: dh $@ --with python2 --buildsystem=python_distutils build: dh build --with python2 --buildsystem=python_distutils $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 clean: clean-docs clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst .PHONY: build clean clean-docs