view debian/rules @ 973:6d691fefdbd1 stable

evolve: fix createmarkers() wrapper to accept an iterable Docstring in mercurial.obsolete says "<relations> must be an iterable of ...", and hgsubversion takes it at its word and passes a generator. Until around Mercurial 3.0, this did not cause any problems, but now it does: in a repo with both evolve and hgsubversion enabled, pushing to Subversion when obsolete changesets are present causes a crash: [...] File "/home/gward/src/hgsubversion/hgsubversion/wrappers.py", line 346, in push obsolete.createmarkers(repo, relations) File "/home/gward/src/hg-stable/mercurial/extensions.py", line 196, in wrap return wrapper(origfn, *args, **kwargs) File "/home/gward/src/hg-evolve/hgext/evolve.py", line 332, in _createmarkers relations[idx] = (prec, sucs, meta) TypeError: 'generator' object does not support item assignment Since hgsubersion is playing by the documented rules, evolve must be the guilty party here.
author Greg Ward <greg@gerg.ca>
date Thu, 05 Jun 2014 18:07:39 -0400
parents d3bfd03cb26e
children 38099dfdcbbe
line wrap: on
line source

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs