Mercurial > evolve
view debian/rules @ 890:7de15cfd79f7
evolve: abort when trying to move a node on top of itself
This provides a clearer error message when evolve misstakenly tries
to move a changeset on top of itself. Before we got an abort with a
cryptic message about trying to rebase a merge changeset.
A proper fix to make sure that evolve never tries to move a node on
top of itself will come in later patches.
author | Olle Lundberg <geek@nerd.sh> |
---|---|
date | Wed, 26 Mar 2014 00:38:14 +0100 |
parents | d3bfd03cb26e |
children | 38099dfdcbbe |
line wrap: on
line source
#!/usr/bin/make -f clean %: dh $@ --with python2 --buildsystem=python_distutils build: dh build --with python2 --buildsystem=python_distutils $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 clean: clean-docs clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst .PHONY: build clean clean-docs