view debian/rules @ 6411:8f52da3cefd0 stable

packaging: sync debian/copyright with Debian official This exactly what went to the Debian official archive [1] as 10.5.3-4. Compare with [2] Basically I had to dig all copyright holders from file preambles and from the Mercurial history. [1]: https://packages.debian.org/bookworm/mercurial-evolve [2]: https://salsa.debian.org/python-team/packages/mercurial-evolve/-/blob/archive/debian/10.5.3-4/debian/copyright
author Georges Racinet <georges.racinet@octobus.net>
date Tue, 14 Feb 2023 14:38:34 +0100
parents 0562705ae984
children 623517b1d83b
line wrap: on
line source

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs
endif

hgsrc_defined:
	# Use "! -z" instead of "-n", because "-n" without arguments is true
	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test: hgsrc_defined
	cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
endif

override_dh_python3:
	# avoid conflict with mercurial's own hgext3rd/__init__.py
	find debian -path '*/hgext3rd/__init__.py' -delete
	dh_python3

override_dh_auto_clean:
	dh_auto_clean
	rm -f tests/*.err
	$(MAKE) -C docs clean