view debian/rules @ 815:916bebf91c41

fastobs: rename var from `node` to `rev` It contains revision (from repo.revs not node).
author Pierre-Yves David <pierre-yves.david@fb.com>
date Thu, 27 Feb 2014 17:20:34 -0800
parents d3bfd03cb26e
children 38099dfdcbbe
line wrap: on
line source

#!/usr/bin/make -f

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs