Mercurial > evolve
view debian/rules @ 1126:aef5e42a4fde
debian: replace clean with override_dh_auto_clean
The current version does not call the default dh_auto_build, which is
a bug. This is required in particular for cleaning the build
directories.
author | Faheem Mitha <faheem@faheem.info> |
---|---|
date | Sat, 11 Oct 2014 02:14:12 +0530 |
parents | f14163c7275a |
children | 87625964c333 |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2 --buildsystem=python_distutils override_dh_auto_build: dh_auto_build $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 override_dh_auto_clean: clean-docs dh_auto_clean rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst .PHONY: build clean clean-docs