Mercurial > evolve
view debian/rules @ 1416:b8a9d2e8c772
test-evolve-bumped: improve tests legibility
This patch introduces in test-evolve-bumped some of the test helpers that we
use in other tests to make the code more legible.
author | Laurent Charignon <lcharignon@fb.com> |
---|---|
date | Fri, 19 Jun 2015 18:16:31 -0700 |
parents | f0978cb993a0 |
children | 9590332b26c8 |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2 --buildsystem=python_distutils override_dh_auto_build: dh_auto_build $(MAKE) -C docs ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: cd tests && python run-tests.py --with-hg=`which hg` --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python2: # avoid conflict with mercurial's own hgext/__init__.py find debian -name __init__.py -delete dh_python2 override_dh_auto_clean: clean-docs dh_auto_clean rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst