view debian/rules @ 1130:be31c34bb341

test: ignore bytes lenght in message We should be storying floating point number as floating point number. So the size of the meta for fm0 format is going to be unstable. We cover them with a glob.
author Pierre-Yves David <pierre-yves.david@fb.com>
date Thu, 16 Oct 2014 14:06:52 -0700
parents 87625964c333
children f0978cb993a0
line wrap: on
line source

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python2 --buildsystem=python_distutils

override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

override_dh_auto_clean: clean-docs
	dh_auto_clean
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst