Mercurial > evolve
view debian/rules @ 5709:d0f73113fcc0 stable
tests: remove trailing "!" from abort messages
CORE-TEST-OUTPUT-UPDATE: 95c4cca641f6
CORE-TEST-OUTPUT-UPDATE: 50afeeeb7b79
CORE-TEST-OUTPUT-UPDATE: 122f0b59f5f0
CORE-TEST-OUTPUT-UPDATE: ca39c45014fa
author | Anton Shestakov <av6@dwimlabs.net> |
---|---|
date | Wed, 02 Dec 2020 09:40:33 +0800 |
parents | 187bd6ade465 |
children | 95500f2f0966 |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS))) override_dh_auto_build: dh_auto_build # Workaround for Sphinx in Debian Buster defaulting to Python 3 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs endif hgsrc_defined: # Use "! -z" instead of "-n", because "-n" without arguments is true test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: hgsrc_defined cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python2: # avoid conflict with mercurial's own hgext3rd/__init__.py find debian -path '*/hgext3rd/__init__.py' -delete dh_python2 override_dh_python3: # avoid conflict with mercurial's own hgext3rd/__init__.py find debian -path '*/hgext3rd/__init__.py' -delete dh_python3 override_dh_auto_clean: dh_auto_clean rm -f tests/*.err $(MAKE) -C docs clean