view debian/rules @ 6665:d2b90c9e5829 stable

uncommit: set uncommit_source extra consistently in interactive mode Previously, the uncommit_source extra was only explicitly set on the temporary changeset created during the uncommit command. Due to a contract mismatch because the extra() method returned a dict that might be reused for multiple callers and this call site expected a fresh dict, the resulting changeset produced by the uncommit command might or might not have had the correct extra nonetheless. This changeset ensures that it will be set consistently. There is a discussion whether the extra() method (in core) should always return a fresh dict. Independent of the outcome of the discussion, this fix should work. I checked that the tests work no matter whether extra() returns a fresh dict or a reused one (current core behavior).
author Manuel Jacob <me@manueljacob.de>
date Thu, 01 Feb 2024 19:13:24 +0100
parents 623517b1d83b
children
line wrap: on
line source

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs
endif

hgsrc_defined:
	# Use "! -z" instead of "-n", because "-n" without arguments is true
	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test: hgsrc_defined
	cd tests && python3 $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
endif

override_dh_python3:
	# avoid conflict with mercurial's own hgext3rd/__init__.py
	find debian -path '*/hgext3rd/__init__.py' -delete
	dh_python3

override_dh_auto_clean:
	dh_auto_clean
	rm -f tests/*.err
	$(MAKE) -C docs clean