view debian/rules @ 1123:d6c065a7a6b1

debian: Add DH_VERBOSE, commented out, for debugging convenience
author Faheem Mitha <faheem@faheem.info>
date Sat, 11 Oct 2014 02:36:46 +0530
parents 38099dfdcbbe
children 25e8f9c43f8a
line wrap: on
line source

#!/usr/bin/make -f
#export DH_VERBOSE=1

clean %:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

clean: clean-docs
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst

.PHONY: build clean clean-docs