Mercurial > evolve
view debian/copyright @ 4728:ef8907df73fc stable
touch: fix the inconsistent behavior of divergence catching logic (issue6107)
When touching a node, the way we check if it can lead to divergence
is we look at the successors sets of the rev being touched. And if
there is successor revs exists (excluding the case when that successor
set is (A,) for rev A) that means there will be divergence and we warn
the user.
This works fine but there is still a case (which is not covered by looking
at successor sets) which can lead to divergence.
That case is: when there is already a revision exists which is divergent
to the revision being touched. And performing the touch would revive
that "dead" divergence. (Dead because one of the revision is obsolete which
is the one we are touching)
And to see if there is any rev which is divergent to a particular rev
we already have a function which we can use here
i.e. `evolvecmd.divergentsets(repo, ctx_being_touched)`
Changes in test file demonstrate the fixed behaviour.
author | Sushil khanchi <sushilkhanchi97@gmail.com> |
---|---|
date | Wed, 17 Jul 2019 17:58:44 +0200 |
parents | e3acb8823900 |
children | fc877278f79e |
line wrap: on
line source
This software was downloaded from https://www.mercurial-scm.org/repo/evolve/ Copyright 2011 Peter Arrenbrecht <peter.arrenbrecht@gmail.com> Logilab SA <contact@logilab.fr> Pierre-Yves David <pierre-yves.david@ens-lyon.org> Patrick Mezard <patrick@mezard.eu> This software may be used and distributed according to the terms of the GNU General Public License version 2 or any later version. On Debian systems, the complete text of the GNU General Public License version 2 can be found in `/usr/share/common-licenses/GPL-2'.