Mercurial > evolve
view debian/rules @ 3651:fa15068a9945
serverminitopic: wrap context.changectx.branch instead of context.changectx
Recently some changes in core resulted in this wrapping of class leading to an
infinite recursion. Let's wrap the particular function instead of wrapping the
whole command.
This fixes test-minitopic.t which was breaking.
author | Pulkit Goyal <7895pulkit@gmail.com> |
---|---|
date | Fri, 06 Apr 2018 23:42:47 +0530 |
parents | c0a685c67c5c |
children | 9fa3585b160f |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2 --buildsystem=python_distutils override_dh_auto_build: dh_auto_build $(MAKE) -C docs hgsrc_defined: # Use "! -z" instead of "-n", because "-n" without arguments is true test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: hgsrc_defined cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python2: # avoid conflict with mercurial's own hgext3rd/__init__.py find debian -path '*/hgext3rd/__init__.py' -delete dh_python2 override_dh_auto_clean: clean-docs dh_auto_clean rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst