Mercurial > evolve
view debian/rules @ 6935:954d7ea5cd67 stable tip
stack: when stack base is obsolete, pick any successor, even if at random
There are situations when s0 is obsolete and we also cannot pick just one
successor for it to use in stack. In such a case, let's pick the "latest"
successor from the first set.
We're assuming that obsutil.successorssets() returns data in the same order (it
should, since it makes sure to sort data internally). Keeping that in mind,
while the successor picked for s0 by this code is not based on any sort of
sophisticated logic, it should nonetheless be the same every time.
This patch is probably not going to completely break anything that was
previously working fine, because the previous behavior was to just abort with
an exception.
author | Anton Shestakov <av6@dwimlabs.net> |
---|---|
date | Sat, 16 Nov 2024 17:01:02 +0400 |
parents | 623517b1d83b |
children |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python3,sphinxdoc --buildsystem=pybuild ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS))) override_dh_auto_build: dh_auto_build $(MAKE) -C docs endif hgsrc_defined: # Use "! -z" instead of "-n", because "-n" without arguments is true test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: hgsrc_defined cd tests && python3 $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python3: # avoid conflict with mercurial's own hgext3rd/__init__.py find debian -path '*/hgext3rd/__init__.py' -delete dh_python3 override_dh_auto_clean: dh_auto_clean rm -f tests/*.err $(MAKE) -C docs clean