Mercurial > hg-stable
comparison contrib/packaging/debian/rules @ 43319:11c85873e106 stable
packaging: avoid running bare "make install" in debian/rules
We change the "override_dh_install" target to "override_dh_auto_install"
in debian/rules (see dh_auto_install(1) for details). This is because we
do not want "make install" to be run automatically as we need the
--install-layout=deb of "setup.py install". Otherwise, files end up in
$DESTDIR/usr/local. At the moment, this is not a problem since files
installed in debian/tmp (the default location) are not packed into
binary packages (because there are debian/mercurial and
debian/mercurial-common directories). This is cleaner to avoid running
make more than needed.
author | Denis Laxalde <denis.laxalde@logilab.fr> |
---|---|
date | Wed, 23 Oct 2019 17:18:57 +0200 |
parents | cdf6db1f4faf |
children | 7b638d25b8e4 |
comparison
equal
deleted
inserted
replaced
43318:cdf6db1f4faf | 43319:11c85873e106 |
---|---|
23 | 23 |
24 override_dh_auto_build: | 24 override_dh_auto_build: |
25 $(MAKE) all | 25 $(MAKE) all |
26 $(MAKE) -C contrib/chg all | 26 $(MAKE) -C contrib/chg all |
27 | 27 |
28 override_dh_install: | 28 override_dh_auto_install: |
29 python3 setup.py install --root "$(CURDIR)"/debian/mercurial --install-layout=deb | 29 python3 setup.py install --root "$(CURDIR)"/debian/mercurial --install-layout=deb |
30 # chg | 30 # chg |
31 make -C contrib/chg \ | 31 make -C contrib/chg \ |
32 DESTDIR="$(CURDIR)"/debian/mercurial \ | 32 DESTDIR="$(CURDIR)"/debian/mercurial \ |
33 PREFIX=/usr \ | 33 PREFIX=/usr \ |