diff setup.py @ 29444:284d742e5611

internals: move the bitmanipulation routines into its own file This is to allow more flexibility with the C sources -- now the bitmanipulation routines can be safely imported without importing Python.h
author Maciej Fijalkowski <fijall@gmail.com>
date Mon, 06 Jun 2016 13:08:13 +0200
parents ee2e4a2c3690
children 2dce3f96ad7b
line wrap: on
line diff
--- a/setup.py	Fri Jun 24 16:12:05 2016 +0100
+++ b/setup.py	Mon Jun 06 13:08:13 2016 +0200
@@ -536,7 +536,9 @@
             'hgext.fsmonitor.pywatchman', 'hgext.highlight',
             'hgext.largefiles', 'hgext.zeroconf', 'hgext3rd']
 
-common_depends = ['mercurial/util.h']
+common_depends = ['mercurial/bitmanipulation.h',
+                  'mercurial/compat.h',
+                  'mercurial/util.h']
 
 osutil_ldflags = []