diff setup.py @ 17606:318fb32b980e

pathencode: new C module with fast encodedir() function Not yet used (will be enabled in a later patch). This patch is a stripped down version of patches originally created by Bryan O'Sullivan <bryano@fb.com>
author Adrian Buehlmann <adrian@cadifra.com>
date Tue, 18 Sep 2012 11:43:30 +0200
parents bf5bb38bcc7c
children b7fff47bb128
line wrap: on
line diff
--- a/setup.py	Tue Sep 18 07:58:50 2012 +0200
+++ b/setup.py	Tue Sep 18 11:43:30 2012 +0200
@@ -421,7 +421,8 @@
     Extension('mercurial.bdiff', ['mercurial/bdiff.c']),
     Extension('mercurial.diffhelpers', ['mercurial/diffhelpers.c']),
     Extension('mercurial.mpatch', ['mercurial/mpatch.c']),
-    Extension('mercurial.parsers', ['mercurial/parsers.c']),
+    Extension('mercurial.parsers', ['mercurial/parsers.c',
+                                    'mercurial/pathencode.c']),
     ]
 
 osutil_ldflags = []