contrib/packaging/mercurial.spec
branchstable
changeset 43358 518655314fc5
parent 43356 5989f697890a
child 45855 de1f4c431619
--- a/contrib/packaging/mercurial.spec	Fri Nov 01 12:47:38 2019 +0100
+++ b/contrib/packaging/mercurial.spec	Fri Nov 01 12:59:22 2019 +0100
@@ -2,7 +2,7 @@
 
 %define withpython %{nil}
 
-%global pythonexe python2
+%global pythonexe python3
 
 %if "%{?withpython}"
 
@@ -39,8 +39,8 @@
 %if "%{?withpython}"
 BuildRequires: readline-devel, openssl-devel, ncurses-devel, zlib-devel, bzip2-devel
 %else
-BuildRequires: python >= %{pythonver}, python-devel, python-docutils >= 0.5
-Requires: python >= %{pythonver}
+BuildRequires: %{pythonexe} >= %{pythonver}, %{pythonexe}-devel, %{pythonexe}-docutils >= 0.5
+Requires: %{pythonexe} >= %{pythonver}
 %endif
 # The hgk extension uses the wish tcl interpreter, but we don't enforce it
 #Requires: tk