setup.py
changeset 44497 5cbe2c0ebc53
parent 44489 ad718271a9eb
child 44499 06b0aa048007
--- a/setup.py	Mon Mar 09 11:18:33 2020 -0700
+++ b/setup.py	Mon Mar 09 17:16:44 2020 +0100
@@ -3,8 +3,6 @@
 #
 # 'python setup.py install', or
 # 'python setup.py --help' for more options
-from __future__ import print_function
-
 import os
 
 # Mercurial will never work on Python 3 before 3.5 due to a lack
@@ -143,7 +141,7 @@
 # (see mercurial/__modulepolicy__.py)
 if hgrustext != 'cpython' and hgrustext is not None:
     if hgrustext:
-        print('unkown HGWITHRUSTEXT value: %s' % hgrustext, file=sys.stderr)
+        printf('unkown HGWITHRUSTEXT value: %s' % hgrustext, file=sys.stderr)
     hgrustext = None
 
 import ctypes