diff setup.py @ 32745:6c4b58422974

setup: introduce dummy copies of setuptools flags Since we're filtering out some egg gunk, we need to emulate these flags which disable eggs so that pip still works.
author Augie Fackler <augie@google.com>
date Tue, 06 Jun 2017 11:02:30 -0400
parents 7dab4c0cdb41
children 9a4adc76c88a
line wrap: on
line diff
--- a/setup.py	Tue Jun 06 10:09:48 2017 -0400
+++ b/setup.py	Tue Jun 06 11:02:30 2017 -0400
@@ -469,6 +469,17 @@
         return os.path.join(self.build_temp, dir, 'hg.exe')
 
 class hginstall(install):
+
+    user_options = install.user_options + [
+        ('old-and-unmanageable', None,
+         'noop, present for eggless setuptools compat'),
+        ('single-version-externally-managed', None,
+         'noop, present for eggless setuptools compat'),
+    ]
+
+    # Also helps setuptools not be sad while we refuse to create eggs.
+    single_version_externally_managed = True
+
     def get_sub_commands(self):
         # Screen out egg related commands to prevent egg generation.  But allow
         # mercurial.egg-info generation, since that is part of modern