diff setup.py @ 25409:95e042d77a5f

wix: move library.zip and all *.pyd into a lib/ folder This makes the root install folder (on Windows) nice and tidy. The only files left in the root folder are: hg.exe python27.dll COPYING.rtf ReadMe.html the last of which was probably out-of-date 7 years ago
author Steve Borho <steve@borho.org>
date Wed, 03 Jun 2015 14:31:19 -0500
parents c6427cd45760
children 4b0fc75f9403
line wrap: on
line diff
--- a/setup.py	Wed May 20 11:31:38 2015 -0500
+++ b/setup.py	Wed Jun 03 14:31:19 2015 -0500
@@ -557,6 +557,8 @@
          'product_version':version}]
     # sub command of 'build' because 'py2exe' does not handle sub_commands
     build.sub_commands.insert(0, ('build_hgextindex', None))
+    # put dlls in sub directory so that they won't pollute PATH
+    extra['zipfile'] = 'lib/library.zip'
 
 if os.name == 'nt':
     # Windows binary file versions for exe/dll files must have the