rust/hg-core/Cargo.toml
changeset 44348 d8d4fa9a7f18
parent 44345 4caac36c66bc
child 44417 8f7c6656ac79
--- a/rust/hg-core/Cargo.toml	Thu Jan 16 11:27:12 2020 +0100
+++ b/rust/hg-core/Cargo.toml	Thu Jan 16 13:34:04 2020 +0100
@@ -4,6 +4,7 @@
 authors = ["Georges Racinet <gracinet@anybox.fr>"]
 description = "Mercurial pure Rust core library, with no assumption on Python bindings (FFI)"
 edition = "2018"
+build = "build.rs"
 
 [lib]
 name = "hg"
@@ -12,6 +13,7 @@
 byteorder = "1.3.1"
 hex = "0.4.0"
 lazy_static = "1.3.0"
+libc = { version = "0.2.66", optional = true }
 memchr = "2.2.0"
 rand = "0.6.5"
 rand_pcg = "0.1.1"
@@ -22,4 +24,11 @@
 
 [dev-dependencies]
 tempfile = "3.1.0"
-pretty_assertions = "0.6.1"
\ No newline at end of file
+pretty_assertions = "0.6.1"
+
+[build-dependencies]
+cc = { version = "1.0.48", optional = true }
+
+[features]
+default = []
+with-re2 = ["cc", "libc"]