--- a/setup.py Fri Dec 12 15:29:39 2014 -0800
+++ b/setup.py Fri Dec 12 15:31:28 2014 -0800
@@ -196,9 +196,13 @@
if hgid.endswith('+'): # propagate the dirty status to the tag
version += '+'
else: # no tag found
- cmd = [sys.executable, 'hg', 'parents', '--template',
- '{latesttag}+{latesttagdistance}-']
- version = runhg(cmd, env) + hgid
+ ltagcmd = [sys.executable, 'hg', 'parents', '--template',
+ '{latesttag}']
+ ltag = runhg(ltagcmd, env)
+ changessincecmd = [sys.executable, 'hg', 'log', '-T', 'x\n', '-r',
+ "only(.,'%s')" % ltag]
+ changessince = len(runhg(changessincecmd, env).splitlines())
+ version = '%s+%s-%s' % (ltag, changessince, hgid)
if version.endswith('+'):
version += time.strftime('%Y%m%d')
elif os.path.exists('.hg_archival.txt'):