setup.py
changeset 9856 ed362d41d1f6
parent 9807 f359d4f528aa
child 9998 4a3c388f8c69
child 10120 fb890a546d44
--- a/setup.py	Wed Nov 11 14:38:59 2009 +0900
+++ b/setup.py	Mon Nov 09 17:41:21 2009 +0100
@@ -121,6 +121,8 @@
     env = {'PYTHONPATH': os.pathsep.join(pypath),
            'HGRCPATH': '',
            'LANGUAGE': 'C'}
+    if 'LD_LIBRARY_PATH' in os.environ:
+        env['LD_LIBRARY_PATH'] = os.environ['LD_LIBRARY_PATH']
     if 'SystemRoot' in os.environ:
         # Copy SystemRoot into the custom environment for Python 2.6
         # under Windows. Otherwise, the subprocess will fail with