contrib/debian/changelog
author Pulkit Goyal <7895pulkit@gmail.com>
Thu, 04 May 2017 04:38:20 +0530
changeset 32209 906da89821ce
parent 30864 dc22729b4ebd
permissions -rw-r--r--
py3: use list of bytes rather than bytestring while extending bytes into lists Python 2: >>> ls = [] >>> ls.extend(b'abc') >>> ls ['a', 'b', 'c'] Python 3: >>> ls = [] >>> ls.extend(b'abc') >>> ls [97, 98, 99] So to make sure things work fine in Py3, this patch does: >>> ls = [] >>> ls.extend([b'a', b'b', b'c']) >>> ls [b'a', b'b', b'c'] After this `hg log -G` works!

mercurial (__VERSION__) __CODENAME__; urgency=medium

  * Automated build performed by upstream.

 -- Mercurial Devel <mercurial-devel@mercurial-scm.org>  __DATE__