Mercurial > hg-stable
view .jshintrc @ 47154:c55afa35a5c8
revlog: rename `hdrsize` to `entry_size` in the C code
This is the size of and index entry, so lets make it clearer.
Differential Revision: https://phab.mercurial-scm.org/D10566
author | Pierre-Yves David <pierre-yves.david@octobus.net> |
---|---|
date | Mon, 03 May 2021 12:20:55 +0200 |
parents | bdd2e18b54c5 |
children |
line wrap: on
line source
{ // Enforcing "eqeqeq" : true, // true: Require triple equals (===) for comparison "forin" : true, // true: Require filtering for..in loops with obj.hasOwnProperty() "freeze" : true, // true: prohibits overwriting prototypes of native objects such as Array, Date etc. "nonbsp" : true, // true: Prohibit "non-breaking whitespace" characters. "undef" : true, // true: Require all non-global variables to be declared (prevents global leaks) // Environments "browser" : true // Web Browser (window, document, etc) }