Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5724
bisect: greatly simplify the ancestor accumulating loop
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5723
bisect: switch to rev-based calculation
- use revlog.parentrevs in search loops
- calculate stop directly in O(N) without reachable
- move badrev check into candidates
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5722
bisect: fix up node vs rev naming
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5721
bisect: clarify some bisection code
- rename __ancestors... to candidates
- remove head parameter (it's always badrev)
- eliminate comprehensions to shrink parents
- num_ancestors -> n_child name fix
- clarify node selection
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5720
bisect: inline num_children function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5719
bisect: remove usage of sets
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5718
bisect: remove stop argument to ancestors function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5717
bisect: use bail_if_changed
- switch to using existing bail_if_changed code
- only abort when we're about to do an update
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5716
cmdutil: make bail_if_changed bail on uncommitted merge
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5715
bisect: remove versionstr
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5714
bisect: simplify lookup
- use repo.lookup directly
- move merge check to check_clean
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5713
bisect: remove redundant clean checks