Tue, 26 May 2015 22:57:35 -0700 bundle2: prefix all bundling debug messages with 'bundle2-ouput:'
Pierre-Yves David <pierre-yves.david@fb.com> [Tue, 26 May 2015 22:57:35 -0700] rev 25314
bundle2: prefix all bundling debug messages with 'bundle2-ouput:' This makes the origin of the message more explicit.
Tue, 26 May 2015 22:49:03 -0700 bundle2: introduce a specific function for bundling debug message
Pierre-Yves David <pierre-yves.david@fb.com> [Tue, 26 May 2015 22:49:03 -0700] rev 25313
bundle2: introduce a specific function for bundling debug message The bundling process is very verbose, we would like to be able to hide such output behind a configuration flag and have it more explicitly referencing bundle2. The first step is to gather all these messages in a dedicated function. The same gathering will be later do for debug message issue by unbundling.
Wed, 27 May 2015 17:01:43 -0700 parsers: simplify the code computing the phases
Laurent Charignon <lcharignon@fb.com> [Wed, 27 May 2015 17:01:43 -0700] rev 25312
parsers: simplify the code computing the phases We recently simplified the code computing the heads of a repo. This patch uses the same simplification for phase computation. We use index_get_parents instead of replicating its code.
Wed, 27 May 2015 17:00:28 -0700 parsers: move index_get_parents's declaration higher
Laurent Charignon <lcharignon@fb.com> [Wed, 27 May 2015 17:00:28 -0700] rev 25311
parsers: move index_get_parents's declaration higher index_get_parents needs to be used in the phase computation code so we need to move its declaration higher to be able to call it. It cannot be moved any higher than that so we won't have any more patch doing the same thing.
Wed, 27 May 2015 15:49:24 -0700 record: add an operation arguments to customize recording ui
Laurent Charignon <lcharignon@fb.com> [Wed, 27 May 2015 15:49:24 -0700] rev 25310
record: add an operation arguments to customize recording ui This patch is part of a series of patches to change the recording ui to reflect the operation currently running (commit, shelve, revert ...). This patch adds a new argument to the recording function to reflect in the UI what operation we are running.
Sun, 26 Apr 2015 18:13:48 +0900 revset: reduce nesting of chained 'or' operations (issue4624)
Yuya Nishihara <yuya@tcha.org> [Sun, 26 Apr 2015 18:13:48 +0900] rev 25309
revset: reduce nesting of chained 'or' operations (issue4624) This reduces the stack depth of chained 'or' operations: - from O(n) to O(1) at the parsing, alias expansion and optimization phases - from O(n) to O(log(n)) at the evaluation phase simplifyinfixops() must be applied immediately after the parsing phase. Otherwise, alias expansion would crash by "maximum recursion depth exceeded" error. Test cases use 'x:y|y:z' instead of 'x|y' because I'm planning to optimize 'x|y' in a different way. Benchmarks: 0) 605b1d32c1c0 1) this patch revset #0: 0 + 1 + 2 + ... + 200 0) wall 0.026347 comb 0.030000 user 0.030000 sys 0.000000 (best of 101) 1) wall 0.023858 comb 0.030000 user 0.030000 sys 0.000000 (best of 112) revset #1: 0 + 1 + 2 + ... + 1000 0) maximum recursion depth exceeded 1) wall 0.483341 comb 0.480000 user 0.480000 sys 0.000000 (best of 20) revset #2: sort(0 + 1 + 2 + ... + 200) 0) wall 0.013404 comb 0.010000 user 0.010000 sys 0.000000 (best of 196) 1) wall 0.006814 comb 0.010000 user 0.010000 sys 0.000000 (best of 375) revset #3: sort(0 + 1 + 2 + ... + 1000) 0) maximum recursion depth exceeded 1) wall 0.035240 comb 0.040000 user 0.040000 sys 0.000000 (best of 100)
Sun, 24 May 2015 14:10:52 +0900 revset: add helper to build balanced addsets from chained 'or' operations
Yuya Nishihara <yuya@tcha.org> [Sun, 24 May 2015 14:10:52 +0900] rev 25308
revset: add helper to build balanced addsets from chained 'or' operations This function will be used by revset.orset() and scmutil.revrange() to reduce the stack depth from O(n) to O(log(n)). We've bikeshed the interface of this function, but we couldn't come to an agreement. So we decided to attempt to make it move forward. marmoute: - new factory function isn't necessary for balanced addsets - addset.__init__ can just recurse, should handle "len(subsets) == 2+" yuja: - want to write all "len(subsets) == 0, 1, 2, 3+" cases in the same function - no recursion in __init__ for cosmetic reason: can't return, can't call __init__ directly I've changed it to a private function so that nobody would be tempted to utilize it.
Sun, 26 Apr 2015 18:27:32 +0900 revset: comment that we can't swap 'or' operands by weight
Yuya Nishihara <yuya@tcha.org> [Sun, 26 Apr 2015 18:27:32 +0900] rev 25307
revset: comment that we can't swap 'or' operands by weight Though the original code did nothing, it tried to optimize the calculation order by weight. But we can't simply swap 'ta' and 'tb' because it would change the order of revisions. For future reference, this patch keeps the modified version of the original code as comment.
Sun, 26 Apr 2015 18:05:23 +0900 parser: add helper to reduce nesting of chained infix operations
Yuya Nishihara <yuya@tcha.org> [Sun, 26 Apr 2015 18:05:23 +0900] rev 25306
parser: add helper to reduce nesting of chained infix operations This will be used to avoid stack overflow caused by chained 'or' operations in revset.
Wed, 27 May 2015 14:28:29 -0500 convert: properly pass null ids through .hgtags (issue4678) stable
Matt Mackall <mpm@selenic.com> [Wed, 27 May 2015 14:28:29 -0500] rev 25305
convert: properly pass null ids through .hgtags (issue4678) Mercurial uses tags of null to mark deletions, but convert was silently discarding these because it had no mapping for them. Thus, it was resurrecting deleted tags.
Wed, 27 May 2015 17:28:55 -0500 commit: improve --close-branch documentation
Matt Mackall <mpm@selenic.com> [Wed, 27 May 2015 17:28:55 -0500] rev 25304
commit: improve --close-branch documentation The confusion about whether this flag closes a whole branch or just a head comes up regularly on IRC, so add some clarification.
Fri, 22 May 2015 13:06:45 -0700 patch: add 'extra' argument to makememctx
Laurent Charignon <lcharignon@fb.com> [Fri, 22 May 2015 13:06:45 -0700] rev 25303
patch: add 'extra' argument to makememctx The uncommit command in evolve needs to create memory context with given extra parameters. This patch allows us to do that instead of always giving them an empty value and having to override it afterwards.
Wed, 27 May 2015 17:41:42 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Wed, 27 May 2015 17:41:42 -0500] rev 25302
merge with stable
Wed, 27 May 2015 13:28:16 -0400 match: normpath the ignore source when expanding the 'subinclude' kind
Matt Harbison <matt_harbison@yahoo.com> [Wed, 27 May 2015 13:28:16 -0400] rev 25301
match: normpath the ignore source when expanding the 'subinclude' kind Windows was previously getting this test failure: --- e:/Projects/hg/tests/test-hgignore.t +++ e:/Projects/hg/tests/test-hgignore.t.err @@ -230,6 +230,7 @@ $ hg status ? dir1/file2 + ? dir1/subdir/subfile3 ? dir1/subdir/subfile4 ? dir2/file1 @@ -241,4 +242,4 @@ $ echo "glob:file*2" > dir1/.hgignoretwo $ hg status | grep file2 - [1] + ? dir1/file2 The problem was 'source' would be in the form "F:\test-hgignore.t\.hgignore", so when pathutil.dirname() split on '/', 'sourceroot' was empty. Therefore, 'path' ended up being relative instead of absolute.
Sat, 23 May 2015 21:18:47 -0700 repair: forbid strip from inside a transaction
Pierre-Yves David <pierre-yves.david@fb.com> [Sat, 23 May 2015 21:18:47 -0700] rev 25300
repair: forbid strip from inside a transaction Stripping inside a transaction will (at best) crash or (at worst) result in very unexpected results. We explicitly forbid it early.
Wed, 27 May 2015 12:14:10 -0400 test-treemanifest: add globs for Windows
Matt Harbison <matt_harbison@yahoo.com> [Wed, 27 May 2015 12:14:10 -0400] rev 25299
test-treemanifest: add globs for Windows
Wed, 27 May 2015 12:11:13 -0400 test-revert-interactive: don't escape the $ for $TESTTMP
Matt Harbison <matt_harbison@yahoo.com> [Wed, 27 May 2015 12:11:13 -0400] rev 25298
test-revert-interactive: don't escape the $ for $TESTTMP Otherwise, sh tries to exec the literal path '${TESTTMP}/editor.sh' on Windows. The test runs clean on OS X both with and without this change.
Tue, 26 May 2015 12:09:04 -0700 changelog: fix bug in heads computation
Laurent Charignon <lcharignon@fb.com> [Tue, 26 May 2015 12:09:04 -0700] rev 25297
changelog: fix bug in heads computation This patch refactors the native computation of heads. It fixes a bug where filtered heads in the pending index could be returned by the native code despite their filtering.
Tue, 26 May 2015 12:08:50 -0700 changelog: change input type of index_get_parents
Laurent Charignon <lcharignon@fb.com> [Tue, 26 May 2015 12:08:50 -0700] rev 25296
changelog: change input type of index_get_parents We were wrongfully using int instead of Py_ssize_t for the revision number.
Fri, 22 May 2015 17:08:59 -0500 branch: don't warn about branches if repository has multiple branches already
Matt Mackall <mpm@selenic.com> [Fri, 22 May 2015 17:08:59 -0500] rev 25295
branch: don't warn about branches if repository has multiple branches already This warning exists to prevent git users from prematurely polluting their namespace when trying out Mercurial. But for repos that already have multiple branches, understanding what branches are is not optional so we should just shut up.
Tue, 26 May 2015 13:02:28 -0700 transaction: really fix _addbackupentry key usage (issue4684) stable
Pierre-Yves David <pierre-yves.david@fb.com> [Tue, 26 May 2015 13:02:28 -0700] rev 25294
transaction: really fix _addbackupentry key usage (issue4684) The fix in fd905b2bea59 is actually wrong. We now use the filename to match what '_addentry'. This whole untested code is quite suspicious. This seems to point that no one is ever running 'tr.find' for a backup file.
Tue, 19 May 2015 13:08:21 -0700 largefiles: avoid match.files() in conditions
Martin von Zweigbergk <martinvonz@google.com> [Tue, 19 May 2015 13:08:21 -0700] rev 25293
largefiles: avoid match.files() in conditions See 9789b4a7c595 (match: introduce boolean prefix() method, 2014-10-28) for reasons to avoid match.files() in conditions.
Tue, 26 May 2015 11:06:43 -0700 largefiles: pass in whole matcher to getstandinmatcher()
Martin von Zweigbergk <martinvonz@google.com> [Tue, 26 May 2015 11:06:43 -0700] rev 25292
largefiles: pass in whole matcher to getstandinmatcher() The choice between the "always" case and the other case is done in getstandinmatcher() and the next patch will change how it's determined based on the matcher, so let's prepare by passing in the matcher, not just the matcher's files.
Tue, 26 May 2015 09:46:48 -0700 largefiles: drop unused 'pats' parameter from getstandinmatcher()
Martin von Zweigbergk <martinvonz@google.com> [Tue, 26 May 2015 09:46:48 -0700] rev 25291
largefiles: drop unused 'pats' parameter from getstandinmatcher() The parameter wasn't used even when it was imported from elsewhere in cfccd3bee7b3 (hgext: add largefiles extension, 2011-09-24).
Tue, 26 May 2015 14:14:36 -0700 devel: rename 'all' to 'all-warnings' (BC)
Pierre-Yves David <pierre-yves.david@fb.com> [Tue, 26 May 2015 14:14:36 -0700] rev 25290
devel: rename 'all' to 'all-warnings' (BC) We have started to isolate extra usecases for developer-only output that is not a warning. As the section has the fairly generic name 'devel' it makes sense to tuck them there. As a result, 'all' becomes a bit misleading so we rename it to 'all-warnings'. This will break some developer setups but the tests are still fine and developers will likely spot this change.
Tue, 26 May 2015 14:52:47 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Tue, 26 May 2015 14:52:47 -0500] rev 25289
merge with stable
Fri, 22 May 2015 14:02:04 -0700 copies: document hack for adding '' to set of dirs
Martin von Zweigbergk <martinvonz@google.com> [Fri, 22 May 2015 14:02:04 -0700] rev 25288
copies: document hack for adding '' to set of dirs The root directory is not normally added to 'dirs' instances (although I think it should be). In copies.mergecopies, we call dirname() to get the directory of a path and then check for containment in the 'dirs' instances ('d1' and 'd2'). In order to easily handle files in the root directory, '/' is added to d1/d2. This results in the empty string being added to the sets, since what comes before the slash in '/' is an empty string. This seems less than obvious, so let's document it.
Tue, 26 May 2015 23:14:50 +0900 test-revset: update test that isn't broken on default branch
Yuya Nishihara <yuya@tcha.org> [Tue, 26 May 2015 23:14:50 +0900] rev 25287
test-revset: update test that isn't broken on default branch "X or wdir()" just works because the default branch includes 40a2cf1c765b.
Tue, 26 May 2015 14:41:00 -0400 pathutil: demote two local functions to just be forwards
Augie Fackler <augie@google.com> [Tue, 26 May 2015 14:41:00 -0400] rev 25286
pathutil: demote two local functions to just be forwards We retain the forwards because it helps code be more ignorant of implementation details, but use forwards instead of our own method definitions since we don't need any truly custom behavior for now.
Tue, 26 May 2015 14:30:48 -0400 pathutil: restate dirname and join as forwards to posixpath
Augie Fackler <augie@google.com> [Tue, 26 May 2015 14:30:48 -0400] rev 25285
pathutil: restate dirname and join as forwards to posixpath I've done this as its own step so that it's easy to see that the posixpath implementations pass the doctests in this package. In a future patch I'll just make these pure forwards of the methods so that things using pathutil can be oblivious to the posix nature of these functions.
(0) -10000 -3000 -1000 -300 -100 -50 -30 +30 +50 +100 +300 +1000 +3000 +10000 tip