Sun, 24 May 2009 18:43:05 +0900 inotify: server: refactor updatestatus()
Nicolas Dumazet <nicdumz.commits@gmail.com> [Sun, 24 May 2009 18:43:05 +0900] rev 8599
inotify: server: refactor updatestatus() * Instead of one entry point, use two entry points, updatefile() and deletefile(), both internally calling the helper function _updatestatus * Do not rely on TypeError to detect the type of oldstatus: use isinstance * The call updatestatus(wpath, None) in deleted() was a bit particular: because no osstat and no newstatus was given, the newstatus was determined using the data stored internally. To replace this exact behavior with the new code, one would use: root, fn = self.split(wpath) d = self.dir(self.tree, root) self.filedeleted(wpath, d.get(fn)) This, however, duplicates code with _updatestatus(), which led us to an interesting question: why are we basing ourselves on repowatcher data to update the status, where everywhere else, we are comparing against dirsate? There is no reason to do this, which is why the new code is: self.filedeleted(wpath, self.repo.dirstate[wpath]) Incidentally, after this, the test for issue1371 passes again.
Sun, 24 May 2009 16:27:56 +0200 convert: deprecate external cvsps, to be removed in 1.4
Patrick Mezard <pmezard@gmail.com> [Sun, 24 May 2009 16:27:56 +0200] rev 8598
convert: deprecate external cvsps, to be removed in 1.4
Sun, 24 May 2009 16:27:50 +0200 osutil: silence uninitialized variable warning
Patrick Mezard <pmezard@gmail.com> [Sun, 24 May 2009 16:27:50 +0200] rev 8597
osutil: silence uninitialized variable warning
Sun, 24 May 2009 16:27:37 +0200 convert/hg: update documentation
Patrick Mezard <pmezard@gmail.com> [Sun, 24 May 2009 16:27:37 +0200] rev 8596
convert/hg: update documentation
Sun, 24 May 2009 16:16:46 +0200 i18n-da: better word for "check"
Henrik Stuart <hg@hstuart.dk> [Sun, 24 May 2009 16:16:46 +0200] rev 8595
i18n-da: better word for "check"
Sun, 24 May 2009 16:14:32 +0200 i18n-da: fixed use of plural form for parent
Henrik Stuart <hg@hstuart.dk> [Sun, 24 May 2009 16:14:32 +0200] rev 8594
i18n-da: fixed use of plural form for parent
Sun, 24 May 2009 15:20:04 +0200 i18n-da: better Danish word for "entry"
Henrik Stuart <hg@hstuart.dk> [Sun, 24 May 2009 15:20:04 +0200] rev 8593
i18n-da: better Danish word for "entry"
Tue, 19 May 2009 09:36:20 +0200 runtest: do not start testing when there is no test
Simon Heimberg <simohe@besonet.ch> [Tue, 19 May 2009 09:36:20 +0200] rev 8592
runtest: do not start testing when there is no test
(0) -3000 -1000 -300 -100 -30 -10 -8 +8 +10 +30 +100 +300 +1000 +3000 +10000 +30000 tip