Mon, 13 Apr 2015 18:11:47 -0400 requires: move requires file writing func from localrepo to scmutil
Drew Gottlieb <drgott@google.com> [Mon, 13 Apr 2015 18:11:47 -0400] rev 24934
requires: move requires file writing func from localrepo to scmutil The logic to read a requires file resides in scmutil, so it's only logical that the logic to write the file should be there too. And now I've typed logic too many times it no longer looks like a word. Logically.
Tue, 05 May 2015 11:15:17 -0700 histedit: fix test-histedit-edit on vfat stable
Durham Goode <durham@fb.com> [Tue, 05 May 2015 11:15:17 -0700] rev 24933
histedit: fix test-histedit-edit on vfat test-histedit-edit was broken because it relied on the HGEDITOR script being executable. Instead, lets just execute 'sh' and pass it the script to run. This seems to be the pattern followed in other tests.
Sun, 03 May 2015 12:28:15 -0400 revset: don't error out if tokens parse as existing symbols
Jordi Gutiérrez Hermoso <jordigh@octave.org> [Sun, 03 May 2015 12:28:15 -0400] rev 24932
revset: don't error out if tokens parse as existing symbols It makes perfect sense for tokens to parse as existing revset symbols (revset functions), and doesn't break anything, since parsing symbols as functions works correctly in the presence of parens. For example, if "only" is a bookmark, this used to error out, hg log -r "only(only, @)" which shouldn't, as the inner "only" is unambiguously not a function. So we just remove the symbolset function and replace its calling site with the stringset function. For the tests, we confirm that "date" and "only" are both parsed as revision names both inside revset expressions (e.g. an expression containing ::) and inside old-style revision expressions (e.g. those containing the name of the revision alone).
Tue, 05 May 2015 12:33:26 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Tue, 05 May 2015 12:33:26 -0500] rev 24931
merge with stable
Sun, 26 Apr 2015 13:43:01 -0400 test-command-template: minor clarification in comment
Jordi Gutiérrez Hermoso <jordigh@octave.org> [Sun, 26 Apr 2015 13:43:01 -0400] rev 24930
test-command-template: minor clarification in comment
Tue, 28 Apr 2015 15:29:15 -0400 test-command-template: test the phase template more precisely
Jordi Gutiérrez Hermoso <jordigh@octave.org> [Tue, 28 Apr 2015 15:29:15 -0400] rev 24929
test-command-template: test the phase template more precisely The current test that greps for "phase:" only checks that the word "phase" is in the output, but does not test that nothing else gets added by this template. This improves these tests by showing a unified
Tue, 28 Apr 2015 16:51:23 -0700 obsolete: speed up unstable computation
Laurent Charignon <lcharignon@fb.com> [Tue, 28 Apr 2015 16:51:23 -0700] rev 24928
obsolete: speed up unstable computation Speed up the computation of the unstable revset by using the not public() revset. In another series of patches, we optimize the not public() revset and together it leads to a 50-100x speedup on the computation of unstable() for our big repos.
Fri, 24 Apr 2015 14:46:30 -0700 obsolete: speed up computation of bumped revset
Laurent Charignon <lcharignon@fb.com> [Fri, 24 Apr 2015 14:46:30 -0700] rev 24927
obsolete: speed up computation of bumped revset Speed up the computation of the bumped revset by using the not public() revset. In another patch series, we optimized the not public() revset. Together, this cuts the cost of the computation of bumped() from 17% of the total time of smartlog on our big repo to under 0.1% of the total time.
Thu, 19 Mar 2015 13:15:20 -0700 run-test: include test name in the return vlog
Pierre-Yves David <pierre-yves.david@fb.com> [Thu, 19 Mar 2015 13:15:20 -0700] rev 24926
run-test: include test name in the return vlog Otherwise using --verbose and --jobs gives useless output.
Tue, 28 Apr 2015 12:31:30 -0400 manifest: document return type of readfast()
Augie Fackler <augie@google.com> [Tue, 28 Apr 2015 12:31:30 -0400] rev 24925
manifest: document return type of readfast() I keep having to ponder out what readfast() means, and it always surprises me. Document the return type in the docstring so that future readers won't have to puzzle this out again.
Mon, 04 May 2015 22:33:29 -0400 archive: always use portable path component separators with subrepos stable
Matt Harbison <matt_harbison@yahoo.com> [Mon, 04 May 2015 22:33:29 -0400] rev 24924
archive: always use portable path component separators with subrepos The previous behavior when archiving a subrepo 's' on Windows was to internally name the file under it 's\file', due to the use of vfs.reljoin(). When printing the file list from the archive on Windows or Linux, the file was named 's\\file'. The archive extracted OK on Windows, but if the archive was brought to a Linux system, it created a file named 's\file' instead of a directory 's' containing 'file'. *.zip format achives seemed not to have the problem, but this was definitely an issue with *.tgz archives. Largefiles actually got this right, but a test is added to keep this from regressing. The subrepo-deep-nested-change.t test was repurposed to archive to a file, since there are several subsequent tests that archive to a directory. The output change is losing the filesystem prefix '../archive_lf' and not listing the directories 'sub1' and 'sub1/sub2'.
Sat, 11 Oct 2014 01:17:40 -0700 revset: narrow the subset using smartset operation in roots()
Pierre-Yves David <pierre-yves.david@fb.com> [Sat, 11 Oct 2014 01:17:40 -0700] rev 24923
revset: narrow the subset using smartset operation in roots() We were manually creating a base with explicit subset testing. We should let smartset magic happen and optimise that logic if needed. benchmark show some massive speedup when "parents set" is huge and "subset" is small. revset: 42:68 and roots(42:tip) 0) wall 0.011322 comb 0.010000 user 0.010000 sys 0.000000 (best of 161) 1) wall 0.002282 comb 0.010000 user 0.010000 sys 0.000000 (best of 1082) Minor speedup in simple case (were fullreposet helps) revset: roots(0::tip) 0) wall 0.095688 comb 0.100000 user 0.100000 sys 0.000000 (best of 85) 1) wall 0.084448 comb 0.080000 user 0.080000 sys 0.000000 (best of 95) revset: roots((0:tip)::) 0) wall 0.146752 comb 0.140000 user 0.140000 sys 0.000000 (best of 58) 1) wall 0.143538 comb 0.140000 user 0.140000 sys 0.000000 (best of 59) And small overhead then the "parents set" is fairly complicated (transforming it into a revset once and for all appears to be faster). revset: roots((tip~100::) - (tip~100::tip)) 0) wall 0.004652 comb 0.010000 user 0.010000 sys 0.000000 (best of 544) 1) wall 0.004878 comb 0.010000 user 0.010000 sys 0.000000 (best of 479) revset: roots((0::) - (0::tip)) 0) wall 0.146587 comb 0.150000 user 0.150000 sys 0.000000 (best of 53) 1) wall 0.157192 comb 0.160000 user 0.160000 sys 0.000000 (best of 53) revset: first(roots((0::) - (0::tip))) 0) wall 0.152924 comb 0.150000 user 0.150000 sys 0.000000 (best of 57) 1) wall 0.153192 comb 0.160000 user 0.160000 sys 0.000000 (best of 55)
Mon, 04 May 2015 10:38:45 -0700 context: make warning message for hidden revision extensible
Laurent Charignon <lcharignon@fb.com> [Mon, 04 May 2015 10:38:45 -0700] rev 24922
context: make warning message for hidden revision extensible Extensions might want to create new filternames and change what revisions are considered hidden or shown. This is the case for inhibit that enables direct access to hidden hashes with the visible-directaccess-nowarn filtername. By using startswith instead of a direct comparison with 'visible' we allow extensions to do that and not work directly on the 'visible' filtername used by core.
Sun, 03 May 2015 14:18:32 -0700 bundlerepo: remove unused 'repo' parameter
Martin von Zweigbergk <martinvonz@google.com> [Sun, 03 May 2015 14:18:32 -0700] rev 24921
bundlerepo: remove unused 'repo' parameter Revision 7c231754a621 (filelog: add file function to open other filelogs, 2011-05-10) added a _file() method to revlog, which also required a 'repo' parameter to be added to bundlefilelog's constructor. The _file() method was then removed in b95a5bb58653 (filelog: remove unused _file method, 2015-01-22), which made the constructor parameter unused, so let's remove that too.
Wed, 22 Apr 2015 15:53:03 -0700 histedit: fix --edit-plan stable
Durham Goode <durham@fb.com> [Wed, 22 Apr 2015 15:53:03 -0700] rev 24920
histedit: fix --edit-plan --edit-plan was completely broken from the command line because it used an old api that was not updated (it would crash with a stack trace). Let's update it and add tests to catch this.
Mon, 04 May 2015 13:15:15 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Mon, 04 May 2015 13:15:15 -0500] rev 24919
merge with stable
Wed, 22 Apr 2015 12:33:08 -0700 localrepo: eliminate local requirements var in init
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:33:08 -0700] rev 24918
localrepo: eliminate local requirements var in init Localrepo's __init__ function creates a local requirements set to add to before it replaces the instance's set with it. This is unnecessary, so let's just use the instance's set directly.
Wed, 22 Apr 2015 12:16:19 -0700 localrepo: rename requirements parameter in stream_in()
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:16:19 -0700] rev 24917
localrepo: rename requirements parameter in stream_in() To avoid confusion from overloading of the variable name "requirements", the requirements is renamed to remotereqs for localrepo's stream_in() function.
Wed, 22 Apr 2015 12:59:12 -0700 localrepo: have stream_in() not modify its argument
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:59:12 -0700] rev 24916
localrepo: have stream_in() not modify its argument Localrepo's stream_in function modified its requirements argument. This is not good practice because it may be unexpected behavior to the caller.
Wed, 22 Apr 2015 12:06:44 -0700 localrepo: make _applyrequirements more specific
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:06:44 -0700] rev 24915
localrepo: make _applyrequirements more specific Localrepo's _applyrequirements function isn't very straightforward about what it does. Its purpose is to both act as a setter for the requirements attribute, and to apply appropriate requirements to the opener's configuration. This change makes the function just focus on the latter responsibility. We rename it as such, and make setting the requirements attribute the responsibility of the caller.
Tue, 21 Apr 2015 17:16:10 -0700 localrepo: make requirements always be a set in localrepo.__init__
Drew Gottlieb <drgott@google.com> [Tue, 21 Apr 2015 17:16:10 -0700] rev 24914
localrepo: make requirements always be a set in localrepo.__init__ The init function used to create a local list, and then convert it to a set before assigning it as a data attribute. This change simplifies the function by having it always be a set, requiring no conversion.
Tue, 21 Apr 2015 16:55:30 -0700 localrepo: eliminate requirements class variable (API)
Drew Gottlieb <drgott@google.com> [Tue, 21 Apr 2015 16:55:30 -0700] rev 24913
localrepo: eliminate requirements class variable (API) Localrepo's requirements class variable was introduced in b090601a80d1 to make requirements modifiable by extensions. A main access point, _baserequirements, still exists, but this change undoes making the class variable to begin with. Without this simplification, there is a class variable with a default value that is only copied, but never directly used. This behavior is moved directly into the _baserequirements function.
Wed, 29 Apr 2015 10:30:58 -0700 changegroup.group: drop 'reorder' parameter
Martin von Zweigbergk <martinvonz@google.com> [Wed, 29 Apr 2015 10:30:58 -0700] rev 24912
changegroup.group: drop 'reorder' parameter Since we always pass self._reorder to self.group(), let's drop the parameter and let group() read from self._reorder itself. There are no other in-tree callers to group().
Wed, 29 Apr 2015 10:38:45 -0700 cg2packer: set reorder=False in __init__ instead of in group()
Martin von Zweigbergk <martinvonz@google.com> [Wed, 29 Apr 2015 10:38:45 -0700] rev 24911
cg2packer: set reorder=False in __init__ instead of in group() The difference between reorder=None (bundle.reorder=auto) and reorder=False is that the generaldelta revlogs get reordered with the former. In cg2packer, group() we check if the revlog uses generaldelta and if reorder=None and then convert that to reorder=False. We are effectively saying that whether or not generaldelta is used, we want reorder=None to mean reorder=False for changegroup 2. To make this clearer, check if reorder=None in the constructor and change it to False there and drop the overriding of group(). Also document the reason for turning reordering off.
Thu, 23 Apr 2015 09:44:22 -0700 changegroup: use 'reorder is None' instead of 'reorder is not True/False'
Martin von Zweigbergk <martinvonz@google.com> [Thu, 23 Apr 2015 09:44:22 -0700] rev 24910
changegroup: use 'reorder is None' instead of 'reorder is not True/False' The config option bundle.reorder can be {on,off,auto}, which gets read into the 'reorder' variable as {True,False,None}. In two places, we need to decide how to handle the None/auto case. I personally find it easier to read those expressions when written to explicitly compare to None.
Thu, 09 Apr 2015 23:47:07 -0400 crecord: fix mixed imports warning
Matt Harbison <matt_harbison@yahoo.com> [Thu, 09 Apr 2015 23:47:07 -0400] rev 24909
crecord: fix mixed imports warning
Fri, 01 May 2015 20:17:00 -0400 windows: add doctest for shellquote()
Matt Harbison <matt_harbison@yahoo.com> [Fri, 01 May 2015 20:17:00 -0400] rev 24908
windows: add doctest for shellquote() This is actual test coverage for issue4629. The test changes in eea3977e6fca were simply the addition of quotes to the output, not ensuring that strings with backslashes are quoted.
Sat, 25 Apr 2015 21:42:07 +0900 template-phases: extend default style instead of duplicating it
Yuya Nishihara <yuya@tcha.org> [Sat, 25 Apr 2015 21:42:07 +0900] rev 24907
template-phases: extend default style instead of duplicating it The phases style started as a copy of the default style at 5c5152af0d15, but we didn't have to copy it because the templater supports %include syntax. This makes sure that the phases style have the same output as the default except for the additional "phase:" row.
Thu, 30 Apr 2015 22:40:18 +0900 commands: hide formatter option as EXPERIMENTAL, not as DEPRECATED stable
Yuya Nishihara <yuya@tcha.org> [Thu, 30 Apr 2015 22:40:18 +0900] rev 24906
commands: hide formatter option as EXPERIMENTAL, not as DEPRECATED 117b9a101f71 introduced the EXPERIMENTAL marker, so we should use it consistently.
Sat, 18 Apr 2015 15:39:26 +0200 keyword: use wvfs.rmtree to remove kwdemo directory
Christian Ebert <blacktrash@gmx.net> [Sat, 18 Apr 2015 15:39:26 +0200] rev 24905
keyword: use wvfs.rmtree to remove kwdemo directory Pass repo.root explicitly as argument to indicate that removal of the temporary repo is intentional in this case.
(0) -10000 -3000 -1000 -300 -100 -50 -30 +30 +50 +100 +300 +1000 +3000 +10000 tip