Bryan O'Sullivan <bos@serpentine.com> [Sun, 27 May 2007 14:26:54 -0700] rev 4488
Introduce find_exe. Use instead of find_in_path for programs.
The behaviour of find_in_path was broken for config options containing
path names, because it always searched the given path, even when not
necessary. The find_exe function is more polite: if the name passed
to it contains a path component, it just returns it.
Bryan O'Sullivan <bos@serpentine.com> [Sun, 27 May 2007 13:50:59 -0700] rev 4487
ui: Rename has_config to has_section.
Bryan O'Sullivan <bos@serpentine.com> [Sun, 27 May 2007 13:41:35 -0700] rev 4486
patchbomb: Defer the import of readline.
If imported at the top of the module, the import appears to succeed,
but raw_input doesn't acquire magic editing fu. I suspect this has
something to do with the newish demandimport code, because the prior
code worked with demandload.