Thu, 27 Dec 2007 23:55:39 -0600 bisect: slightly improve the help message
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5729
bisect: slightly improve the help message
Thu, 27 Dec 2007 23:55:39 -0600 bisect: remove stale test function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5728
bisect: remove stale test function
Thu, 27 Dec 2007 23:55:39 -0600 bisect: use array.array rather than lists for ancestor lists
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5727
bisect: use array.array rather than lists for ancestor lists This nearly doubles performance and cuts memory usage in half on large bisections.
Thu, 27 Dec 2007 23:55:39 -0600 bisect: switch individual ancestor lists from dict to list
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5726
bisect: switch individual ancestor lists from dict to list This saves quite a lot of memory and increases performance
Thu, 27 Dec 2007 23:55:39 -0600 bisect: turn ancestors into an array
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5725
bisect: turn ancestors into an array This makes things faster and eliminates the separate stop hash
Thu, 27 Dec 2007 23:55:39 -0600 bisect: greatly simplify the ancestor accumulating loop
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5724
bisect: greatly simplify the ancestor accumulating loop
Thu, 27 Dec 2007 23:55:39 -0600 bisect: switch to rev-based calculation
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5723
bisect: switch to rev-based calculation - use revlog.parentrevs in search loops - calculate stop directly in O(N) without reachable - move badrev check into candidates
Thu, 27 Dec 2007 23:55:39 -0600 bisect: fix up node vs rev naming
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5722
bisect: fix up node vs rev naming
Thu, 27 Dec 2007 23:55:39 -0600 bisect: clarify some bisection code
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5721
bisect: clarify some bisection code - rename __ancestors... to candidates - remove head parameter (it's always badrev) - eliminate comprehensions to shrink parents - num_ancestors -> n_child name fix - clarify node selection
Thu, 27 Dec 2007 23:55:39 -0600 bisect: inline num_children function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5720
bisect: inline num_children function
Thu, 27 Dec 2007 23:55:39 -0600 bisect: remove usage of sets
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5719
bisect: remove usage of sets
Thu, 27 Dec 2007 23:55:39 -0600 bisect: remove stop argument to ancestors function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5718
bisect: remove stop argument to ancestors function
Thu, 27 Dec 2007 23:55:39 -0600 bisect: use bail_if_changed
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5717
bisect: use bail_if_changed - switch to using existing bail_if_changed code - only abort when we're about to do an update
Thu, 27 Dec 2007 23:55:39 -0600 cmdutil: make bail_if_changed bail on uncommitted merge
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5716
cmdutil: make bail_if_changed bail on uncommitted merge
Thu, 27 Dec 2007 23:55:39 -0600 bisect: remove versionstr
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5715
bisect: remove versionstr
Thu, 27 Dec 2007 23:55:39 -0600 bisect: simplify lookup
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5714
bisect: simplify lookup - use repo.lookup directly - move merge check to check_clean
Thu, 27 Dec 2007 23:55:39 -0600 bisect: remove redundant clean checks
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5713
bisect: remove redundant clean checks
Thu, 27 Dec 2007 23:55:39 -0600 bisect: fold in two trivial functions
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5712
bisect: fold in two trivial functions
Thu, 27 Dec 2007 23:55:39 -0600 bisect: remove two unused functions
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5711
bisect: remove two unused functions
Thu, 27 Dec 2007 23:55:36 -0600 update test-merge-types
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:36 -0600] rev 5710
update test-merge-types
Thu, 27 Dec 2007 22:49:01 -0600 ui: allow default when prompting
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:49:01 -0600] rev 5709
ui: allow default when prompting
Thu, 27 Dec 2007 22:47:44 -0600 merge: add flag merging intelligence
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:47:44 -0600] rev 5708
merge: add flag merging intelligence - properly handle all 27 combinations of flags - prompt on conflicts
Thu, 27 Dec 2007 22:47:41 -0600 util: remove set_exec and set_link methods
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:47:41 -0600] rev 5707
util: remove set_exec and set_link methods
Thu, 27 Dec 2007 22:29:21 -0600 patch: use util.set_flags
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:29:21 -0600] rev 5706
patch: use util.set_flags
Thu, 27 Dec 2007 22:29:17 -0600 convert/svn: use util.set_flags
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:29:17 -0600] rev 5705
convert/svn: use util.set_flags
Thu, 27 Dec 2007 22:27:48 -0600 merge: use util.set_flags
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:27:48 -0600] rev 5704
merge: use util.set_flags
Thu, 27 Dec 2007 22:27:47 -0600 wwrite: simplify with util.set_flags
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:27:47 -0600] rev 5703
wwrite: simplify with util.set_flags - always attempt to delete the file (gets rid of read-only message) - always write as a normal file - use set_flags to convert to link or set exec
Thu, 27 Dec 2007 22:27:45 -0600 util: add new set_flags method
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 22:27:45 -0600] rev 5702
util: add new set_flags method This is more efficient than calling set_link and set_exec
(0) -3000 -1000 -300 -100 -50 -28 +28 +50 +100 +300 +1000 +3000 +10000 +30000 tip