Wed, 06 Apr 2016 19:09:12 +0000 tests: add new test for #! shebang lines
timeless <timeless@mozdev.org> [Wed, 06 Apr 2016 19:09:12 +0000] rev 28879
tests: add new test for #! shebang lines * use #!/bin/sh not e.g. #!/usr/bin/sh * use #!/usr/bin/env python not e.g. #!/usr/bin/python
Sun, 27 Mar 2016 13:00:28 -0700 largefiles: introduce push --lfrev to control which revisions are pushed
Mads Kiilerich <madski@unity3d.com> [Sun, 27 Mar 2016 13:00:28 -0700] rev 28878
largefiles: introduce push --lfrev to control which revisions are pushed The default of pushing all largefiles referenced in outgoing revisions is safe, but also expensive and sometimes not what is needed. We thus introduce a --lfrev option, similar to what pull already has. By specifying an empty set of revisions (or null), it is possible to get lazy (and insecure!) pushes of revisions without referenced largefiles, similar to how pull works.
Wed, 13 Apr 2016 01:45:45 +0200 largefiles: don't access repo.changelog directly in getlfilestoupload
Mads Kiilerich <madski@unity3d.com> [Wed, 13 Apr 2016 01:45:45 +0200] rev 28877
largefiles: don't access repo.changelog directly in getlfilestoupload Make it possible to pass both nodes and revisions to getlfilestoupload.
Wed, 13 Apr 2016 01:09:11 +0200 localrepo: refactor prepushoutgoinghook to take a pushop
Mads Kiilerich <madski@unity3d.com> [Wed, 13 Apr 2016 01:09:11 +0200] rev 28876
localrepo: refactor prepushoutgoinghook to take a pushop prepushoutgoinghook was introduced in 6c383c871fdb and largefiles is the only in-tree use of it. Refactor it to be more useful for other use cases in largefiles.
Tue, 29 Mar 2016 00:08:25 +0900 parser: unify parser function of alias declaration and definition
Yuya Nishihara <yuya@tcha.org> [Tue, 29 Mar 2016 00:08:25 +0900] rev 28875
parser: unify parser function of alias declaration and definition We no longer have to keep them separately.
Tue, 29 Mar 2016 00:05:14 +0900 revset: unify function that parses alias declaration and definition
Yuya Nishihara <yuya@tcha.org> [Tue, 29 Mar 2016 00:05:14 +0900] rev 28874
revset: unify function that parses alias declaration and definition We no longer need separate parsers. Only difference between _parsealiasdecl() and _parsealiasdefn() is whether or not to flatten 'or' tree. Since alias declaration should have no 'or' operator, there was no practical difference.
Mon, 29 Feb 2016 18:10:07 +0900 parser: move alias definition parser to common rule-set class
Yuya Nishihara <yuya@tcha.org> [Mon, 29 Feb 2016 18:10:07 +0900] rev 28873
parser: move alias definition parser to common rule-set class The original _parsealiasdefn() function is split into common _builddefn() and revset-specific _parsealiasdefn(). revset._relabelaliasargs() is removed as it is no longer used. The doctests are ported by using the dummy parse().
Mon, 29 Feb 2016 18:00:51 +0900 parser: move _relabelaliasargs() to common rule-set class
Yuya Nishihara <yuya@tcha.org> [Mon, 29 Feb 2016 18:00:51 +0900] rev 28872
parser: move _relabelaliasargs() to common rule-set class This has no doctest because it will be covered by _builddefn() introduced by the next patch. revset._relabelaliasargs() will be removed soon.
Mon, 29 Feb 2016 17:54:03 +0900 parser: move alias declaration parser to common rule-set class
Yuya Nishihara <yuya@tcha.org> [Mon, 29 Feb 2016 17:54:03 +0900] rev 28871
parser: move alias declaration parser to common rule-set class The original _parsealiasdecl() function is split into common _builddecl() and revset-specific _parsealiasdecl(). And the original _parsealiasdecl() call is temporarily replaced by rules._builddecl(), which should be eliminated later. The doctests are mostly ported by using the dummy parse(), but the test for 'foo bar' is kept in _parsealiasdecl() as it checks if "pos != len(decl)" is working. Also, 'foo($1)' test is added to make sure the alias tokenizer can handle '$1' symbol, which is the only reason why we need _parsealiasdecl().
Sun, 03 Apr 2016 16:55:23 +0900 parser: add stub class that will host alias parsing and expansion
Yuya Nishihara <yuya@tcha.org> [Sun, 03 Apr 2016 16:55:23 +0900] rev 28870
parser: add stub class that will host alias parsing and expansion This class will keep syntax rules that are necessary to parse and expand aliases. The implementations will be extracted from the revset module. In order to make the porting easier, this class keeps parsedecl and parsedefn separately, which will be unified later. Also, getlist and funcnode will be refactored by future patches for better handling of the template aliases. The following public functions will be added: aliasrules.build(decl, defn) -> aliasobj parse decl and defn into an object that keeps alias name, arguments and replacement tree. aliasrules.buildmap(aliasitems) -> aliasdict helper to build() a dict of alias objects from a list of (decl, defn) aliasrules.expand(aliasdict, tree) -> tree expand aliases in tree recursively Because these functions aren't introduced by this series, there would remain a few wrapper functions in the revset module. These ugly wrappers should be eliminated by the next series. This class is considered an inheritable namespace, which will host only class/static methods. That's because it won't have no object-scope variables. I'm not a big fan of using class as a syntax sugar, but I admit it can improve code readability at some level. So let's give it a try.
Mon, 29 Feb 2016 17:43:39 +0900 revset: narrow scope of "except ParseError" block in _parsealiasdecl()
Yuya Nishihara <yuya@tcha.org> [Mon, 29 Feb 2016 17:43:39 +0900] rev 28869
revset: narrow scope of "except ParseError" block in _parsealiasdecl() This helps to factor out a common function. "if True" will be removed soon.
Tue, 12 Apr 2016 04:06:50 -0700 obsstore: move delete function from obsstore class to repair module
Kostia Balytskyi <ikostia@fb.com> [Tue, 12 Apr 2016 04:06:50 -0700] rev 28868
obsstore: move delete function from obsstore class to repair module Since one of the original patches was accepted already and people on the mailing list still have suggestions as to how this should be improved, I'm implementing those suggestions in the following patches (this and the ones that might follow).
Tue, 12 Apr 2016 03:40:53 -0700 debugobsolete: style fixes to debugobsolete that slipped from original commit
Kostia Balytskyi <ikostia@fb.com> [Tue, 12 Apr 2016 03:40:53 -0700] rev 28867
debugobsolete: style fixes to debugobsolete that slipped from original commit
Wed, 09 Mar 2016 10:47:33 -0500 import: document --exact behavior in more detail
Matt Mackall <mpm@selenic.com> [Wed, 09 Mar 2016 10:47:33 -0500] rev 28866
import: document --exact behavior in more detail
Mon, 11 Apr 2016 19:46:50 +0200 util: add doctest to datestr()
Adrian Buehlmann <adrian@cadifra.com> [Mon, 11 Apr 2016 19:46:50 +0200] rev 28865
util: add doctest to datestr()
Tue, 12 Apr 2016 00:30:28 +0200 date: fix boundary check of negative integer
Florent Gallaire <fgallaire@gmail.com> [Tue, 12 Apr 2016 00:30:28 +0200] rev 28864
date: fix boundary check of negative integer
Sun, 10 Apr 2016 22:00:34 +0100 chg: server exited with code 0 without being connectable is an error
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 22:00:34 +0100] rev 28863
chg: server exited with code 0 without being connectable is an error Before this patch, if the server started by chg has exited with code 0 without creating a connectable unix domain socket at the specified address, chg will exit with code 0, which is not the correct behavior. It can happen, for example, CHGHG is set to /bin/true. This patch addresses the issue by checking the exit code of the server and printing a new error message if the server exited normally but cannot be reached.
Fri, 08 Apr 2016 23:33:28 -0700 shelve: refactor directory name into constant
Oleg Afanasyev <olegaf@fb.com> [Fri, 08 Apr 2016 23:33:28 -0700] rev 28862
shelve: refactor directory name into constant Shelve directory name extracted into constant to avoid typos/duplication.
Sun, 10 Apr 2016 20:55:37 +0000 pycompat: switch to util.stringio for py3 compat
timeless <timeless@mozdev.org> [Sun, 10 Apr 2016 20:55:37 +0000] rev 28861
pycompat: switch to util.stringio for py3 compat
Sun, 10 Apr 2016 21:32:08 +0000 py3: use multi-line import in test-wireproto.py
timeless <timeless@mozdev.org> [Sun, 10 Apr 2016 21:32:08 +0000] rev 28860
py3: use multi-line import in test-wireproto.py The reason I did it is that I had a later commit that was adding to the list.
Sun, 10 Apr 2016 21:32:05 +0000 py3: use absolute_import in test-hgweb-non-interactive.t
timeless <timeless@mozdev.org> [Sun, 10 Apr 2016 21:32:05 +0000] rev 28859
py3: use absolute_import in test-hgweb-non-interactive.t
Sun, 10 Apr 2016 21:32:01 +0000 py3: use absolute_import in test-hgweb-no-request-uri.t
timeless <timeless@mozdev.org> [Sun, 10 Apr 2016 21:32:01 +0000] rev 28858
py3: use absolute_import in test-hgweb-no-request-uri.t
Sun, 10 Apr 2016 21:31:58 +0000 py3: use absolute_import in test-hgweb-no-path-info.t
timeless <timeless@mozdev.org> [Sun, 10 Apr 2016 21:31:58 +0000] rev 28857
py3: use absolute_import in test-hgweb-no-path-info.t
Mon, 11 Apr 2016 00:18:27 +0100 chg: use fsetcloexec instead of closing lockfd manually
Jun Wu <quark@fb.com> [Mon, 11 Apr 2016 00:18:27 +0100] rev 28856
chg: use fsetcloexec instead of closing lockfd manually Since we have the fsetcloexec utility function, use it instead of closing lockfd manually.
Mon, 11 Apr 2016 00:17:17 +0100 chg: extract the logic of setting FD_CLOEXEC to a utility function
Jun Wu <quark@fb.com> [Mon, 11 Apr 2016 00:17:17 +0100] rev 28855
chg: extract the logic of setting FD_CLOEXEC to a utility function Setting FD_CLOEXEC is useful for other fds such like lockfd and sockdirfd, move the logic from hgc_open to util.
Sun, 10 Apr 2016 03:14:32 +0100 chg: add fchdirx as a utility function
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 03:14:32 +0100] rev 28854
chg: add fchdirx as a utility function As part of the series to support long socket paths, we need to use fchdir and check its result in several places. Make it a utility function.
Sun, 10 Apr 2016 22:58:11 +0100 chg: check lockfd at freecmdserveropts
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 22:58:11 +0100] rev 28853
chg: check lockfd at freecmdserveropts We check for sockdirfd at freecmdserveropts but not lockfd, which is a bit strange to people new to the code. Add a comment and an assert to make it clear that lockfd should be closed earlier.
Sun, 10 Apr 2016 23:56:00 +0100 chg: add sockdirfd to cmdserveropts
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 23:56:00 +0100] rev 28852
chg: add sockdirfd to cmdserveropts As part of the series to support long socket paths, we need to add the fd of the directory to the cmdserveropts structure so we can use basenames instead of full paths for sockname, redirectsockname, and lockfile.
Sun, 10 Apr 2016 21:56:05 +0100 chg: fix spelling in the error message about error waiting for cmdserver
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 21:56:05 +0100] rev 28851
chg: fix spelling in the error message about error waiting for cmdserver This is a trivial spelling and grammar fix.
Sun, 10 Apr 2016 11:02:58 -0700 sslutil: document and slightly refactor validation logic
Gregory Szorc <gregory.szorc@gmail.com> [Sun, 10 Apr 2016 11:02:58 -0700] rev 28850
sslutil: document and slightly refactor validation logic This main purpose of this patch is to make it clearer that fingerprint pinning takes precedence over CA verification. This will make subsequent refactoring to the validation code easier to read.
(0) -10000 -3000 -1000 -300 -100 -50 -30 +30 +50 +100 +300 +1000 +3000 +10000 tip