Wed, 21 Jul 2010 22:22:28 +0200 hgwebdir: allow pure relative globs in paths stable
Mads Kiilerich <mads@kiilerich.com> [Wed, 21 Jul 2010 22:22:28 +0200] rev 11677
hgwebdir: allow pure relative globs in paths This allows the (to me, in some setups) obvious configuration: [paths] / = * or / = ** Relative paths used to work with [collections] even though it isn't documented. Perhaps it should be documented?
Thu, 22 Jul 2010 15:26:26 -0400 alias: ensure checksignature() is applied directly to the command (issue2286) stable
Brodie Rao <brodie@bitheap.org> [Thu, 22 Jul 2010 15:26:26 -0400] rev 11676
alias: ensure checksignature() is applied directly to the command (issue2286) Aliased commands that received bad arguments would raise TypeError instead of SignatureError. This only affected commands that weren't wrapped by extensions. Using util.checksignature() in cmdalias.__call__() ensures SignatureError is raised correctly.
Sat, 24 Jul 2010 00:38:08 +0200 dispatch: give better error message when cwd doesn't exist (issue2293) stable
Mads Kiilerich <mads@kiilerich.com> [Sat, 24 Jul 2010 00:38:08 +0200] rev 11675
dispatch: give better error message when cwd doesn't exist (issue2293) Previous behavior wasn't very helpful: $ hg st foo abort: No such file or directory Now we tell more about what failed: abort: error getting current working directory: No such file or directory
Thu, 22 Jul 2010 23:18:38 +0900 i18n: safety writing into non-ASCII named files on any shell implementation stable
FUJIWARA Katsunori <foozy@lares.dti.ne.jp> [Thu, 22 Jul 2010 23:18:38 +0900] rev 11674
i18n: safety writing into non-ASCII named files on any shell implementation some shell implementation (e.g.: dash) can not handle redirection into non-ASCII UTF-8 named file correctly.
Sun, 25 Jul 2010 17:18:35 -0500 convert: handle closed branch heads in hg-hg conversion (issue2185)
Matt Mackall <mpm@selenic.com> [Sun, 25 Jul 2010 17:18:35 -0500] rev 11673
convert: handle closed branch heads in hg-hg conversion (issue2185)
Sun, 25 Jul 2010 17:10:32 -0500 check-code: add warning on lines over 80 characters
Matt Mackall <mpm@selenic.com> [Sun, 25 Jul 2010 17:10:32 -0500] rev 11672
check-code: add warning on lines over 80 characters
Sun, 25 Jul 2010 08:22:03 -0700 Remove variable output affected by length of TMPDIR.
Lee Cantey <lcantey@gmail.com> [Sun, 25 Jul 2010 08:22:03 -0700] rev 11671
Remove variable output affected by length of TMPDIR. If the temporary directory is longer than /tmp then it's possible that the Subject line will get wrapped by the headencode function.
Sun, 25 Jul 2010 13:10:57 +0200 chunkbuffer: split big strings directly in chunkbuffer
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sun, 25 Jul 2010 13:10:57 +0200] rev 11670
chunkbuffer: split big strings directly in chunkbuffer
Sun, 25 Jul 2010 10:05:38 +0900 localrepo.status: move fixup concatenation inside if block for clarity
Nicolas Dumazet <nicdumz.commits@gmail.com> [Sun, 25 Jul 2010 10:05:38 +0900] rev 11669
localrepo.status: move fixup concatenation inside if block for clarity clean += fixup only makes sense if fixup is not empty; it should be inside the "if fixup" test.
Sat, 24 Jul 2010 17:23:08 +0200 chunkbuffer: targetsize isn't used outside of read()
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sat, 24 Jul 2010 17:23:08 +0200] rev 11668
chunkbuffer: targetsize isn't used outside of read()
Sat, 24 Jul 2010 15:21:39 +0200 chunkbuffer: use list instead of cStringIO
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sat, 24 Jul 2010 15:21:39 +0200] rev 11667
chunkbuffer: use list instead of cStringIO
Sat, 24 Jul 2010 15:20:29 +0200 chunkbuffer: use for/else to detect end of iteration
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sat, 24 Jul 2010 15:20:29 +0200] rev 11666
chunkbuffer: use for/else to detect end of iteration
Sat, 24 Jul 2010 00:15:29 +0200 changegroup*(): use enumerate when possible
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sat, 24 Jul 2010 00:15:29 +0200] rev 11665
changegroup*(): use enumerate when possible
Sat, 24 Jul 2010 00:03:19 +0200 changegroupsubset(): with the fix, prune() is actually useful in the testsuite
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sat, 24 Jul 2010 00:03:19 +0200] rev 11664
changegroupsubset(): with the fix, prune() is actually useful in the testsuite
Thu, 22 Jul 2010 13:48:34 +0200 test-permissions: echo commands to make output readable
Martin Geisler <mg@aragost.com> [Thu, 22 Jul 2010 13:48:34 +0200] rev 11663
test-permissions: echo commands to make output readable
Fri, 23 Jul 2010 00:04:18 +0200 changegroupsubset: simplify knownheads/has_cl_set computation
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Fri, 23 Jul 2010 00:04:18 +0200] rev 11662
changegroupsubset: simplify knownheads/has_cl_set computation
Thu, 22 Jul 2010 23:54:57 +0200 changegroupsubset(): ancestors() is not inclusive, we need to remove the "heads"
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 22 Jul 2010 23:54:57 +0200] rev 11661
changegroupsubset(): ancestors() is not inclusive, we need to remove the "heads"
Thu, 22 Jul 2010 23:44:14 +0200 changegroupsubset(): move comment at the right place
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 22 Jul 2010 23:44:14 +0200] rev 11660
changegroupsubset(): move comment at the right place
Thu, 22 Jul 2010 23:13:03 +0200 changegroupsubset(): refactor the prune() functions
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 22 Jul 2010 23:13:03 +0200] rev 11659
changegroupsubset(): refactor the prune() functions
Thu, 22 Jul 2010 22:23:54 +0200 Merge with stable
Martin Geisler <mg@lazybytes.net> [Thu, 22 Jul 2010 22:23:54 +0200] rev 11658
Merge with stable
Thu, 22 Jul 2010 21:43:45 +0200 help: make helptable a list instead of a tuple stable
Martin Geisler <mg@lazybytes.net> [Thu, 22 Jul 2010 21:43:45 +0200] rev 11657
help: make helptable a list instead of a tuple The table should always have been a list so that extensions can append their own help topics -- hgsubversion would like to do this now.
Sat, 03 Jul 2010 08:28:23 +0200 test-command-template: test 'children' template keyword
Jason Harris <jason@jasonfharris.com> [Sat, 03 Jul 2010 08:28:23 +0200] rev 11656
test-command-template: test 'children' template keyword
Sat, 03 Jul 2010 05:24:16 +0200 templates: 'children' keyword
Jason Harris <jason@jasonfharris.com> [Sat, 03 Jul 2010 05:24:16 +0200] rev 11655
templates: 'children' keyword The template keyword 'parents' is already present and this just provides the complimentary template keyword.
Thu, 22 Jul 2010 16:51:45 +0200 changegroupsubset(): change variable names, simplify lookup logic
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 22 Jul 2010 16:51:45 +0200] rev 11654
changegroupsubset(): change variable names, simplify lookup logic
Thu, 22 Jul 2010 16:18:33 +0200 changegroup(): used "linkrev" instead of "revlink"
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 22 Jul 2010 16:18:33 +0200] rev 11653
changegroup(): used "linkrev" instead of "revlink"
Thu, 22 Jul 2010 15:32:26 +0200 fix comment
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 22 Jul 2010 15:32:26 +0200] rev 11652
fix comment
Thu, 22 Jul 2010 08:24:56 -0500 Merge with stable
Matt Mackall <mpm@selenic.com> [Thu, 22 Jul 2010 08:24:56 -0500] rev 11651
Merge with stable
Thu, 22 Jul 2010 08:17:38 -0500 revset: fix ancestor subset handling (issue2298) stable
Matt Mackall <mpm@selenic.com> [Thu, 22 Jul 2010 08:17:38 -0500] rev 11650
revset: fix ancestor subset handling (issue2298)
(0) -10000 -3000 -1000 -300 -100 -50 -28 +28 +50 +100 +300 +1000 +3000 +10000 +30000 tip