Gregory Szorc <gregory.szorc@gmail.com> [Sat, 12 Sep 2015 12:47:00 -0700] rev 26241
revlog: rename generic "i" variable to "indexdata"
Increase readability.
Gregory Szorc <gregory.szorc@gmail.com> [Sat, 12 Sep 2015 11:31:56 -0700] rev 26240
hg: always create new localrepository instance
cachedlocalrepo.copy() didn't actually create new localrepository
instances. This meant that the new thread isolation code in hgweb wasn't
actually using separate localrepository instances, even though it was
properly using separate cachedlocalrepo instances.
Because the behavior of the API changed, the single caller in hgweb had
to be refactored to always call _webifyrepo() or it may not have used
the proper filter.
I confirmed via print() debugging that id(repo) is in fact different on
each thread. This was not the case before.
For reasons I can't yet explain, this does not fix issue4756. I suspect
there is shared cache somewhere that isn't thread safe.
timeless@mozdev.org [Thu, 10 Sep 2015 19:45:46 -0400] rev 26239
test-bad-extension: reduce dependencies on other things
test-bad-extension would jitter if the format of the first line
of hg help changed, which isn't relevant to its goal.
timeless@mozdev.org [Thu, 10 Sep 2015 20:22:37 -0400] rev 26238
help: fix help argument parsing and documentation
support combining -c and -e
previously -k was misdocumented:
* the first line didn't mention it
* the help half implied you could do help -k keyword topic
with these changes, -k just changes the search method
support -c and -e for -k searches
timeless@mozdev.org [Thu, 10 Sep 2015 10:48:20 -0400] rev 26237
minirst: establish leveling for nested definitions
Jordi Gutiérrez Hermoso <jordigh@octave.org> [Sun, 13 Sep 2015 16:30:21 -0400] rev 26236
dispatch: use the right context manager to deactivate demandimport
In e86d12404d69 I very embarrassingly wrote a patch with the
completely wrong function name. This should fix it.
Augie Fackler <augie@google.com> [Thu, 10 Sep 2015 10:50:03 -0400] rev 26235
ui: improve docs on ui.log
This makes the documentation on ui.log line up with the use of that
interface in blackbox.
Yuya Nishihara <yuya@tcha.org> [Sat, 12 Sep 2015 00:21:41 +0900] rev 26234
templater: switch ctx of list expression to rev of revset() (BC)
Because revset() function generates a list of revisions, it seems sensible
to switch the ctx as well where a list expression will be evaluated. I think
"{revset(...) % "..."}" expression wasn't considered well when it was
introduced at cda9d2b6beab.
Yuya Nishihara <yuya@tcha.org> [Thu, 10 Sep 2015 23:32:36 +0900] rev 26233
fileset: handle error of string unescaping
Yuya Nishihara <yuya@tcha.org> [Thu, 10 Sep 2015 23:29:55 +0900] rev 26232
revset: handle error of string unescaping