Peter Arrenbrecht <peter.arrenbrecht@gmail.com> [Tue, 14 Jun 2011 22:58:00 +0200] rev 14624
setdiscovery: batch heads and known(ownheads)
This means that we now discover both subset conditions (local<remote and
remote<local) in a single roundtrip without ever constructing an actual
sample (which takes a bit of client CPU).
Peter Arrenbrecht <peter.arrenbrecht@gmail.com> [Tue, 14 Jun 2011 22:56:20 +0200] rev 14623
wireproto: make a number of commands batchable
Makes lookup, heads, known, branchmap, pushkey, and listkeys batchable.
It could, for instance, be interesting to use this to batch calls to
lookup when a pull or clone has multiple --rev arguments. The next patch
is going to batch heads and known to slightly tune discovery.
Peter Arrenbrecht <peter.arrenbrecht@gmail.com> [Tue, 14 Jun 2011 22:52:58 +0200] rev 14622
wireproto: add batching support to wirerepository
Adds the plumbing and wire call for batched execution, but does not
batch-enable any methods yet.
Peter Arrenbrecht <peter.arrenbrecht@gmail.com> [Tue, 14 Jun 2011 22:51:26 +0200] rev 14621
wireproto: add basic command batching infrastructure
Note that localbatch will not be used until we actually have a localpeer to
use it with.
Yuya Nishihara <yuya@tcha.org> [Wed, 15 Jun 2011 01:50:49 +0900] rev 14620
mq: make qrefresh/qfold keep wlock until saving patch status
Because q.refresh() changes nodeid, .hg/patches/status gets invalid until
q.savedirty(). This patch changes mq not to unlock repository of incomplete
state.
Wagner Bruna <wbruna@softwareexpress.com.br> [Tue, 14 Jun 2011 20:08:35 -0300] rev 14619
bugzilla: fix typo in documentation
Idan Kamara <idankk86@gmail.com> [Tue, 14 Jun 2011 20:25:38 +0300] rev 14618
dispatch: fix for-loop variable name
Ingo Bressler <dev@ingobressler.net> [Tue, 14 Jun 2011 13:29:25 +0200] rev 14617
notify: send changesets on 'outgoing' hook, updated doc
Stephen Thorne <stephen@thorne.id.au> [Tue, 14 Jun 2011 13:31:32 +1000] rev 14616
sslutil: Restore missing imports of socket and httplib to sslutil
Two imports were omitted in the restructure of the code creating
sslutil.py, socket and httplib are required when the 'ssl' module
cannot be imported, restoring these imports allows mercurial to run
on python2.4+2.5.
Idan Kamara <idankk86@gmail.com> [Wed, 08 Jun 2011 14:54:47 +0300] rev 14615
dispatch: assign I/O descriptors from the request to the ui
Idan Kamara <idankk86@gmail.com> [Wed, 08 Jun 2011 01:39:20 +0300] rev 14614
ui: use I/O descriptors internally
and as a result:
- fix webproto to redirect the ui descriptors instead of sys.stdout/err
- fix sshserver to use the ui descriptors
Idan Kamara <idankk86@gmail.com> [Tue, 07 Jun 2011 13:39:09 +0300] rev 14613
dispatch: add I/O descriptors to the request
Idan Kamara <idankk86@gmail.com> [Tue, 07 Jun 2011 13:39:09 +0300] rev 14612
ui: add I/O descriptors
Patrick Mezard <pmezard@gmail.com> [Tue, 14 Jun 2011 23:26:35 +0200] rev 14611
import: add --bypass option
This feature is more a way to test patching without a working directory than
something people asked about. Adding a --rev option to specify the parent patch
revision would make it a little more useful.
What this change introduces is patch.repobackend class which let patches be
applied against repository revisions. The caller must supply a filestore object
to receive patched content, which can be turned into a memctx with
patch.makememctx() helper.
Patrick Mezard <pmezard@gmail.com> [Tue, 14 Jun 2011 23:24:40 +0200] rev 14610
import: separate parents selection from working dir update
This will be useful when patching without updating the dirstate
Patrick Mezard <pmezard@gmail.com> [Tue, 14 Jun 2011 23:24:34 +0200] rev 14609
patch: extend filtestore to store an optional copy source
This will help wrapping filestores in memctx.
Martin Geisler <mg@aragost.com> [Tue, 14 Jun 2011 16:38:34 +0200] rev 14608
paper/coal: use fixed width for diffstat +/- link
The plus and minus characters are normally not the same width in a
non-monospace font, and this made the line length change when the
diffstat display was toggled.
The square brackets are not rendered in a monospace font to ensure
that they align with the parenthesis on the same line.
Martin Geisler <mg@aragost.com> [Tue, 14 Jun 2011 16:33:46 +0200] rev 14607
hg: rename opts argument to peeropts in clone
This should make it clearer that the options are used with remoteui
only and are not used otherwise in hg.clone.
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 16:25:18 -0500] rev 14606
hg: move peerschemes back to schemes
This will avoid breaking things with extensions until peers are fully
separated from repos.
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 14:53:23 -0500] rev 14605
hg: rearrange peer scheme lookup
There is now only peer scheme lookup. Repository lookup goes through
peer scheme lookup. When peer and repo types are finally separated,
repo lookup will use peer.local() to get a repository object.
The underbar is dropped so that extensions can patch the table.
Idan Kamara <idankk86@gmail.com> [Mon, 13 Jun 2011 14:56:00 +0300] rev 14604
forget, remove: don't note on nonexistent file twice
before:
$ hg forget foo
foo: No such file or directory
not removing foo: file is already untracked
after:
$ hg forget foo
foo: No such file or directory
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 12:51:38 -0500] rev 14603
localrepo: local() returns self
Temporary measure for introducing peers
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 12:51:37 -0500] rev 14602
tests: avoid instability in test-convert-cvs-synthetic
Idan Kamara <idankk86@gmail.com> [Mon, 13 Jun 2011 00:19:26 +0300] rev 14601
dispatch: propagate ui command options to the local ui (issue2523)
so the ui object passed to pre/post python hooks has the verbose flag
(and the rest) set correctly
Idan Kamara <idankk86@gmail.com> [Sun, 12 Jun 2011 23:30:39 +0300] rev 14600
mq: catch correct exception when calling changelog.rev()
Idan Kamara <idankk86@gmail.com> [Sun, 12 Jun 2011 17:26:58 +0300] rev 14599
rebase: preserve mq series order after rebasing (issue2849)
Idan Kamara <idankk86@gmail.com> [Sun, 12 Jun 2011 17:26:20 +0300] rev 14598
run-tests: verbose log ignored test
Ingo Proetel <proetel@aicas.de> [Fri, 10 Jun 2011 10:58:10 +0200] rev 14597
record: add white space diff options
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:53:58 +0200] rev 14596
mq: rename abort_if_wdir_patched to abortifwdirpatched
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:48:47 +0200] rev 14595
mq: rename partial_name to partialname
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:47:21 +0200] rev 14594
mq: rename write_list to writelist
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:45:48 +0200] rev 14593
mq: rename series_dirty to seriesdirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:44:34 +0200] rev 14592
mq: rename applied_dirty to applieddirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:43:03 +0200] rev 14591
mq: rename guards_dirty to guardsdirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:41:58 +0200] rev 14590
mq: rename active_guards to activeguards
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:40:35 +0200] rev 14589
mq: rename guards_path to guardspath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:39:14 +0200] rev 14588
mq: rename status_path to statuspath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:38:04 +0200] rev 14587
mq: rename series_path to seriespath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:11:49 +0200] rev 14586
mq: rename series_end to seriesend
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:09:29 +0200] rev 14585
mq: rename full_series_end to fullseriesend
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:07:46 +0200] rev 14584
mq: rename check_reserved_name to checkreservedname
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:06:32 +0200] rev 14583
mq: rename check_localchanges to checklocalchanges
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:05:20 +0200] rev 14582
mq: rename check_substate to checksubstate
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:03:38 +0200] rev 14581
mq: rename check_toppatch to checktoppatch
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:02:14 +0200] rev 14580
mq: rename save_dirty to savedirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:00:56 +0200] rev 14579
mq: rename explain_pushable to explainpushable
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:59:35 +0200] rev 14578
mq: rename set_active to setactive
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:58:16 +0200] rev 14577
mq: rename set_guards to setguards
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:57:21 +0200] rev 14576
mq: rename check_guard to checkguard
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:55:46 +0200] rev 14575
mq: rename parse_series to parseseries
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:54:25 +0200] rev 14574
mq: rename find_series to findseries
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:40:27 +0200] rev 14573
mq: rename series_guards to seriesguards
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:06:11 +0200] rev 14572
mq: rename full_series to fullseries
Steven Brown <StevenGBrown@gmail.com> [Sat, 11 Jun 2011 21:24:50 +0800] rev 14571
paper, coal: display diffstat on the changeset page
Displayed in a row of the changeset summary table, underneath the list of
files. When the page is loaded, only the diff summary is displayed. The full
diffstat is only displayed when the [+] link is selected.
Steven Brown <StevenGBrown@gmail.com> [Sat, 11 Jun 2011 21:11:43 +0800] rev 14570
web: provide diff summary to the changeset page
This is the same message displayed at the end of the "diff --stat" command.
For example, "9 files changed, 1651 insertions(+), 2 deletions(-)".
The webutil.diffstatgen function allows the diffstat data to be lazily
calculated only once and then re-used.
Matt Mackall <mpm@selenic.com> [Sat, 11 Jun 2011 14:14:53 -0500] rev 14569
tests: fix up date ambiguity in cvs test
Matt Mackall <mpm@selenic.com> [Sat, 11 Jun 2011 14:14:52 -0500] rev 14568
hg: split peer and repo lookup tables
Patrick Mezard <pmezard@gmail.com> [Sat, 11 Jun 2011 14:40:25 +0200] rev 14567
tests: rename test-git-import.t into test-import-git.t
This is consistent with other test-import* tests.
Patrick Mezard <pmezard@gmail.com> [Sat, 11 Jun 2011 14:17:25 +0200] rev 14566
patch: generalize the use of patchmeta in applydiff()
- Add patchmeta.copy() and emit copies from iterhunks. Modifying patchmeta
instances in applydiff() makes things simpler.
- Rename selectfile() into makepatchmeta(). It is responsible for creating
patchmeta for regular patches.
- Pass patchmeta objects to patchfile() directly
patchmeta instances were associated with git patches, for regular patches we
had to pass additional variables to tell the patch intent to patchfile().
Instead, we generate patchmeta for regular patches and pass them. This will
also help with patch filtering by matcher objects.
Patrick Mezard <pmezard@gmail.com> [Sat, 11 Jun 2011 14:14:13 +0200] rev 14565
patch: stop updating changed files set in applydiff()
This information is more correctly returned by backends.
The extra updated file removed from test-mq-merge.t output came from changes
from git patches being counted before being really applied in some cases.