equal
deleted
inserted
replaced
14 dh_python2 |
14 dh_python2 |
15 find debian/mercurial/usr/share -type d -empty -delete |
15 find debian/mercurial/usr/share -type d -empty -delete |
16 |
16 |
17 override_dh_install: |
17 override_dh_install: |
18 python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial --install-layout=deb |
18 python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial --install-layout=deb |
|
19 # chg |
|
20 make -C contrib/chg \ |
|
21 DESTDIR=$(CURDIR)/debian/mercurial \ |
|
22 PREFIX=/usr \ |
|
23 clean install |
19 # remove arch-independent python stuff |
24 # remove arch-independent python stuff |
20 find $(CURDIR)/debian/mercurial/usr/lib \ |
25 find $(CURDIR)/debian/mercurial/usr/lib \ |
21 ! -name '*.so' ! -type d -delete , \ |
26 ! -name '*.so' ! -type d -delete , \ |
22 -type d -empty -delete |
27 -type d -empty -delete |
23 python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial-common --install-layout=deb |
28 python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial-common --install-layout=deb |
29 cp contrib/hg-ssh $(CURDIR)/debian/mercurial-common/usr/bin |
34 cp contrib/hg-ssh $(CURDIR)/debian/mercurial-common/usr/bin |
30 mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/mercurial |
35 mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/mercurial |
31 cp contrib/hgk $(CURDIR)/debian/mercurial-common/usr/share/mercurial |
36 cp contrib/hgk $(CURDIR)/debian/mercurial-common/usr/share/mercurial |
32 mkdir -p $(CURDIR)/debian/mercurial-common/etc/mercurial/hgrc.d/ |
37 mkdir -p $(CURDIR)/debian/mercurial-common/etc/mercurial/hgrc.d/ |
33 cp contrib/debian/*.rc $(CURDIR)/debian/mercurial-common/etc/mercurial/hgrc.d/ |
38 cp contrib/debian/*.rc $(CURDIR)/debian/mercurial-common/etc/mercurial/hgrc.d/ |
|
39 # completions |
34 mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/bash-completion/completions |
40 mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/bash-completion/completions |
35 cp contrib/bash_completion $(CURDIR)/debian/mercurial-common/usr/share/bash-completion/completions/hg |
41 cp contrib/bash_completion $(CURDIR)/debian/mercurial-common/usr/share/bash-completion/completions/hg |
36 mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/zsh/vendor-completions |
42 mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/zsh/vendor-completions |
37 cp contrib/zsh_completion $(CURDIR)/debian/mercurial-common/usr/share/zsh/vendor-completions/_hg |
43 cp contrib/zsh_completion $(CURDIR)/debian/mercurial-common/usr/share/zsh/vendor-completions/_hg |
38 rm $(CURDIR)/debian/mercurial-common/usr/bin/hg |
44 rm $(CURDIR)/debian/mercurial-common/usr/bin/hg |