comparison mercurial/localrepo.py @ 14220:21b8ce4d3331

rename path_auditor to pathauditor The Mercurial 1.9 release is moving a lot of stuff around anyway and we are already moving path_auditor from util.py to scmutil.py for that release. So this seems like a good opportunity to do such a rename. It also strengthens the current project policy to avoid underbars in names.
author Adrian Buehlmann <adrian@cadifra.com>
date Fri, 06 May 2011 09:54:06 +0200
parents 0013d3eeb826
children df2399663392
comparison
equal deleted inserted replaced
14219:c33427080671 14220:21b8ce4d3331
28 def __init__(self, baseui, path=None, create=0): 28 def __init__(self, baseui, path=None, create=0):
29 repo.repository.__init__(self) 29 repo.repository.__init__(self)
30 self.root = os.path.realpath(util.expandpath(path)) 30 self.root = os.path.realpath(util.expandpath(path))
31 self.path = os.path.join(self.root, ".hg") 31 self.path = os.path.join(self.root, ".hg")
32 self.origroot = path 32 self.origroot = path
33 self.auditor = scmutil.path_auditor(self.root, self._checknested) 33 self.auditor = scmutil.pathauditor(self.root, self._checknested)
34 self.opener = scmutil.opener(self.path) 34 self.opener = scmutil.opener(self.path)
35 self.wopener = scmutil.opener(self.root) 35 self.wopener = scmutil.opener(self.root)
36 self.baseui = baseui 36 self.baseui = baseui
37 self.ui = baseui.copy() 37 self.ui = baseui.copy()
38 38